Bug 240345 - Fedora 7 or FC7 kernel panic issue with 2.6.21 kernel on booting with vmware
Fedora 7 or FC7 kernel panic issue with 2.6.21 kernel on booting with vmware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 240346 240347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 12:45 EDT by ketan kothari
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 14:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vmware vmx file settings for scsi controller (1.22 KB, text/plain)
2007-05-16 12:45 EDT, ketan kothari
no flags Details

  None (edit)
Description ketan kothari 2007-05-16 12:45:31 EDT
Description of problem:
I have a VMWare virtual machine setup for Fedora Core 7 or FC7 as guest on 
Windows XP SP2 as a host. This is a fully patched rawhide Fedora version. I 
have noticed that after the kernel upgrade to 2.6.21, Fedora fails to boot with 
error message : No volume groups found. Last working kernel was 2.6.20-
1.2925.fc7 and it still allows me to boot successfully.


Version-Release number of selected component (if applicable):
2.6.21-1.3149.fc7

How reproducible:
Every time I try to boot it gives the following message.
Red Hat nash version 6.0.8 starting
  Reading all physical volumes. This mat take a while...
  No volume groups found
  Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol01)


Steps to Reproduce:
1. Boot the Fedora using 2.6.21 Kernel
2.
3.
  
Actual results:
---------------------------------------------------------------------------
Booting 'Fedora (2.6.21-1.3149.fc7)

root (hd0,0)
 filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.21-1.3149.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
 [Linux-bzImage, setup=0x1e00, size=0x1cc8341]
initrd /initrd-2.6.21-1.3149.fc7.img
 [Linux-initrd @ 0x1fb83000, 0x35c9a9 bytes]
 
uncompressing Linux... Ok, booting the kernel
Red Hat nash version 6.0.8 starting
  Reading all physical volumes. This mat take a while...
  No volume groups found
  Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol01)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
----------------------------------------------------------------------------

Expected results:
Able to boot successfully.

Additional info:
This happens with only vmware and virtual hard disks using scsi isilogic driver.

Here is some of the reports that i could find on Red hat bugzilla
--------------------------------------------------------------------------------
-------
Bugzilla Bug 230849: f7t2 install does not find hd
Bugzilla Bug 230703: Fusion MPT SPI Host driver not detecting any disks

Comment #1 From Jeremy Katz 
on 2007-03-05 15:42 EST
[reply]
 
The mptspi driver in the current kernel doesn't seem to like the vmware 
emulated disks.

This is preventing me from booting into my vmware. I have to manually exclude 
the kernel package from removal process by yum to  be able to boot 
successfully. I am able to boot successfully with kernel 2.6.20-1.2925.fc7
Comment 1 ketan kothari 2007-05-16 12:45:31 EDT
Created attachment 154844 [details]
vmware vmx file settings for scsi controller
Comment 2 ketan kothari 2007-05-16 12:50:55 EDT
*** Bug 240347 has been marked as a duplicate of this bug. ***
Comment 3 ketan kothari 2007-05-16 12:51:27 EDT
*** Bug 240346 has been marked as a duplicate of this bug. ***
Comment 4 ketan kothari 2007-05-16 14:21:36 EDT
The issue got resolved after I upgraded the vmware player from 1.0.4 to Version 
2. version 2 (2.0.0build-45731). The latest kernel version is 2.6.21-1.3149.fc7 
with which it is working fine.

One issue I encountered after installation of vmware player 2.0, that it gives 
the following ,message. 
Error while opening the virtual machine. The virtual machine appears to be in 
use. 
Deleting the .lck file from the directory that contains the image resolved the 
issue. 

Note You need to log in before you can comment on or make changes to this bug.