Bug 240374 - ValueError: need more than 3 values to unpack
ValueError: need more than 3 values to unpack
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 16:08 EDT by Peter Ennis
Modified: 2014-01-21 17:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 17:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ennis 2007-05-16 16:08:29 EDT
Description of problem:

[root@fc6 run]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
extras    : ################################################## 5923/5923
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 381, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 150, in doCommand
    return base.updatePkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 676, in updatePkgs
    self.doUpdateSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 373, in
doUpdateSetup
    self.up.doUpdates()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 283, in
doUpdates
    for (arch, e,v,r) in newpkgs[(n, a)]:
ValueError: need more than 3 values to unpack
[root@fc6 run]# 

Version-Release number of selected component (if applicable):


How reproducible:

yum update

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
[root@fc6 run]# uname -a
Linux fc6.adaept.com 2.6.20-1.2948.fc6 #1 SMP Fri Apr 27 19:48:40 EDT 2007 i686
i686 i386 GNU/Linux
[root@fc6 run]#
Comment 1 Seth Vidal 2007-05-16 17:05:48 EDT
what version of yum is that?
Comment 2 Peter Ennis 2007-05-16 20:29:55 EDT
[root@fc6 ~]# yum --version
3.0.6
[root@fc6 ~]# 
Comment 3 Jeremy Katz 2007-06-13 14:25:17 EDT
Does this still occur for you?
Comment 4 Peter Ennis 2007-06-13 17:41:17 EDT
Updated: autofs.i386 1:5.0.1-0.rc3.31 docbook-utils.noarch 0:0.6.14-8.fc6
file.i386 0:4.21-1.fc6 gd.i386 0:2.0.33-11.fc6 gd-devel.i386 0:2.0.33-11.fc6
gtk2.i386 0:2.10.12-1.fc6 gtk2-devel.i386 0:2.10.12-1.fc6 htmlview.noarch
0:4.0.0-3.fc6 libexif.i386 0:0.6.15-1.fc6 openoffice.org-calc.i386
1:2.0.4-5.5.23 openoffice.org-core.i386 1:2.0.4-5.5.23 openoffice.org-draw.i386
1:2.0.4-5.5.23 openoffice.org-graphicfilter.i386 1:2.0.4-5.5.23
openoffice.org-impress.i386 1:2.0.4-5.5.23 openoffice.org-math.i386
1:2.0.4-5.5.23 openoffice.org-writer.i386 1:2.0.4-5.5.23
openoffice.org-xsltfilter.i386 1:2.0.4-5.5.23 pam.i386 0:0.99.6.2-3.22.fc6
pam-devel.i386 0:0.99.6.2-3.22.fc6 paps.i386 0:0.6.6-20.fc6 postgresql-libs.i386
0:8.1.9-1.fc6 shadow-utils.i386 2:4.0.17-13.fc6 spamassassin.i386 0:3.1.9-1.fc6
xorg-x11-drv-savage.i386 0:2.1.2-3.fc6 xorg-x11-server-Xorg.i386 0:1.1.1-47.9.fc6
Complete!
[root@fc6 ~]# 

[root@fc6 ~]# yum --version
3.0.6
[root@fc6 ~]# 

Seems to be working.
Comment 5 Jeremy Katz 2007-06-13 17:57:53 EDT
Hrmm... no clue at all what would have been causing it.  If it reoccurs, please
reopen and we'll try to get some more information
Comment 6 Phil 2007-08-06 16:46:25 EDT
I am having same problem...

yum 3.0.1

Linux localhost.localdomain 2.6.18-1.2868.fc6 #1 SMP Fri Dec 15 17:32:54 EST
2006 i686 i686 i386 GNU/Linux

# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                     100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 1.2 kB    00:00     
core                      100% |=========================| 1.1 kB    00:00     
extras                    100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 102, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 359, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 150, in doCommand
    return base.updatePkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 632, in updatePkgs
    self.doUpdateSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 366, in
doUpdateSetup
    self.up.doUpdates()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 283, in
doUpdates
    for (arch, e,v,r) in newpkgs[(n, a)]:
ValueError: need more than 3 values to unpack
Comment 7 Seth Vidal 2007-08-06 17:12:20 EDT
stop using 3.0.1 - update it to 3.0.6

Note You need to log in before you can comment on or make changes to this bug.