Bug 240384 - RPM tags FILEUIDS FILEGIDS missing
Summary: RPM tags FILEUIDS FILEGIDS missing
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 4.5
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-16 22:02 UTC by John Horne
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 10:17:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Horne 2007-05-16 22:02:35 UTC
Description of problem:
The following URL from your site shows that the rpm tags FILEUIDS/FILEGIDS are
defined:

http://www.redhat.com/docs/books/max-rpm/max-rpm-html/ch-queryformat-tags.html

However, using them gives an error.

Version-Release number of selected component (if applicable):
rpm-4.3.3-22_nonptl

How reproducible:
Run this command:

  rpm -qf --queryformat '[%{FILEUIDS}:%{FILEGIDS}:%{FILENAMES}\n]' /bin/ps


Steps to Reproduce:
1. Run the above command
2.
3.
  
Actual results:
An error message is shown:

  error: incorrect format: unknown tag

Expected results:
File userids/gids should be listed for the relevant package.

Additional info:

Comment 1 Jeff Johnson 2007-05-17 03:04:48 UTC
Neither of FILEUIDS or FILEGIDS have been populated since (at least) rpm-2.4 in December, 1997.

NOTABUG

Comment 2 John Horne 2007-05-17 10:14:27 UTC
So shouldn't the rpm command show nothing for their values rather than giving an
error then? If I request the FILEMD5S for a symbolic link it shows no value,
rather than an error.

Comment 3 Paul Nasrat 2007-05-17 10:17:27 UTC
Maximum RPM is somewhat dated, as jbj says those are legacy header entries and
not populated by rpmbuild. Instead you should use:

rpm -qf --queryformat '[%{FILEUSERNAME}:%{FILEGROUPNAME}:%{FILENAMES}\n]' 

You've specified not queryable tags - rpm --querytags | grep IDS shows you that,
the error is correct. FILEMD5 is a queryable tag that may be empty.  It's a
different case.


Note You need to log in before you can comment on or make changes to this bug.