Bug 240530 - When suspending to RAM, hangs with "Suspending consoles"
When suspending to RAM, hangs with "Suspending consoles"
Status: CLOSED DUPLICATE of bug 238938
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Regression
Depends On:
Blocks: 237760
  Show dependency treegraph
 
Reported: 2007-05-18 05:13 EDT by Bastien Nocera
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 09:18:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-05-18 05:13:47 EDT
2.6.21-1.3167.fc7 on a Dell Latitude D420

Trying to suspend to RAM leaves me waiting for "Suspending consoles" to finish,
which it never does.

Nigel C mentioned that this could be related to tick timers, and that pressing a
key should let it go through, but that doesn't work.

The stock F7 test 4 worked (kernel from ~1 ago, ie. it worked on Tuesday).
Comment 1 Bastien Nocera 2007-05-18 05:20:28 EDT
that, ~1 week ago. I'm using DaveJ's kernels, the regression is recent.

From my /var/log/messages, I believe it worked fine using:
2.6.21-1.3144.fc7
and broke after the update to:
2.6.21-1.3163.fc7

Can't test though, as the older kernels have disappeared.
Comment 2 Will Woods 2007-05-18 09:50:09 EDT
IIRC it'd only be tick timers if you're running i386 and not x86_64 - what arch
is the machine? (I'm not immediately familiar with that system model number.)

You can get kernels from the build system here:
http://koji.fedoraproject.org/koji/packageinfo?packageID=8

Could you also look at the Sleep Quirk Debugger, here:
http://people.freedesktop.org/~hughsient/temp/quirk/quirk-debug.html

and see if any of the advice there helps?
Comment 3 Bastien Nocera 2007-05-18 09:54:53 EDT
(In reply to comment #2)
> IIRC it'd only be tick timers if you're running i386 and not x86_64 - what arch
> is the machine? (I'm not immediately familiar with that system model number.)

It's i686 (it's a laptop, don't know any x86-64 laptops).

> You can get kernels from the build system here:
> http://koji.fedoraproject.org/koji/packageinfo?packageID=8

I'll double-check, if that's interesting.

> Could you also look at the Sleep Quirk Debugger, here:
> http://people.freedesktop.org/~hughsient/temp/quirk/quirk-debug.html

I know about it, but read the bug description again, it won't help. The laptop
hangs while suspending, not when resuming.

> and see if any of the advice there helps?

I don't see any advices for the problem I'm seeing. It's definitely a kernel
problem, and a regression. It worked with earlier F7 test kernels.
Comment 4 Bastien Nocera 2007-05-20 18:31:03 EDT
I tested:
2.6.21-1.3149.fc7
2.6.21-1.3144.fc7
2.6.21-1.3163.fc7
and none of them seem to work, although I'm certain 2.6.21-1.3149.fc7 used to
work (that's the kernel I used to do suspend testing last Tuesday).
Comment 5 Bastien Nocera 2007-05-20 19:31:29 EDT
Tested with 2.6.21-1.3174.fc7, same problem.
Doing "echo mem > /sys/power/state" from run-level 3 (rather than using g-p-m)
shows the same hang. I can still type, and switch VTs though, but not run
anything (trying to log in to a console doesn't work).
Comment 6 Bastien Nocera 2007-05-20 20:06:19 EDT
Pressing Alt+SysRq+Fn+T (the Fn is necessary to get to the SysRq, this is a
laptop...) doesn't bring me any output (despite /proc/sys/kernel/sysrq being set
to 1).

I also tested with the nmi_watchdog, and I'm not seeing anything appearing. I
also used the builtin Dell diagnostics, and all the tests pass (just in case it
might just be a hardware problem).

Any hints on debugging that?
Comment 7 Nigel Cunningham 2007-05-21 20:09:14 EDT
That would make sense - if the console is suspended, any printks won't make it
to the screen until the console is resumed. This, of course, makes it a bit hard
to diagnose. Any chance of using something like KDB to dig deeper?
Comment 8 Bastien Nocera 2007-05-22 08:11:44 EDT
After Nigel mentioned it could be a driver issue, I tested and saw that the
iwl3495 driver is to blame.

Richard Hughes tested on his X60 with the same result (mine is a Dell Latitude
D420).

kernel-2.6.21-1.3180.fc7 still has the problem, and kernel-2.6.21-1.3186.fc7
isn't bootable (bug 240850).
Comment 9 John W. Linville 2007-05-22 09:18:22 EDT

*** This bug has been marked as a duplicate of 238938 ***

Note You need to log in before you can comment on or make changes to this bug.