Bug 240533 - yum prints error summary heading followed by no data
Summary: yum prints error summary heading followed by no data
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-18 09:36 UTC by David Kovalsky
Modified: 2014-03-31 23:44 UTC (History)
1 user (show)

Fixed In Version: 3.2.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 20:29:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Kovalsky 2007-05-18 09:36:15 UTC
Today's had a dependency problem, yum printed out the transaction check errors
end the error summary heading, but no errors in the error summary.

I would say you should not print the error summary heading if it has no errors
to print under it. Or print some error summary.

My yum output:
[root@kovinek ~]# yum --disablerepo=atrpms update
Loading "installonlyn" plugin
Loading "changelog" plugin
Loading "kernel-module" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kdebase.i386 6:3.5.6-10.fc7 set to be updated
---> Package kdelibs.i386 6:3.5.6-7.fc7 set to be updated
--> Processing Dependency: kde-settings-kdm for package: kdebase
--> Processing Dependency: libIlmImf.so.4 for package: kdelibs
--> Processing Dependency: kde-settings for package: kdebase
--> Processing Dependency: libIlmImf.so.4 for package: kdebase
--> Processing Dependency: kde-settings >= 3.5 for package: kdelibs
--> Processing Dependency: redhat-artwork-kde >= 7.0.0-8 for package: kdebase
--> Processing Dependency: libHalf.so.4 for package: kdelibs
--> Processing Dependency: libjasper.so.1 for package: kdelibs
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package kde-settings-kdm.noarch 0:3.5-23.fc7 set to be updated
---> Package kde-settings.noarch 0:3.5-23.fc7 set to be updated
---> Package jasper.i386 0:1.900.1-1.fc7 set to be updated
---> Package redhat-artwork-kde.i386 0:7.0.0-8.fc7 set to be updated
---> Package OpenEXR.i386 0:1.4.0a-3.fc6 set to be updated
--> Processing Dependency: libfltk.so.1.1 for package: OpenEXR
--> Processing Dependency: libfltk_gl.so.1.1 for package: OpenEXR
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package fltk.i386 0:1.1.8-0.3.r5750.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 kdebase                 i386       6:3.5.6-10.fc7   fedora-base        28 M
 kdelibs                 i386       6:3.5.6-7.fc7    fedora-base        18 M
Installing for dependencies:
 OpenEXR                 i386       1.4.0a-3.fc6     fedora-base       416 k
 fltk                    i386       1.1.8-0.3.r5750.fc7  fedora-base       424 k
 jasper                  i386       1.900.1-1.fc7    fedora-base       173 k
 kde-settings            noarch     3.5-23.fc7       fedora-base        15 k
 kde-settings-kdm        noarch     3.5-23.fc7       fedora-base        15 k
 redhat-artwork-kde      i386       7.0.0-8.fc7      fedora-base       559 k

Transaction Summary
=============================================================================
Install      6 Package(s)
Update       2 Package(s)
Remove       0 Package(s)

Total download size: 48 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/config/kdm conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xaccess conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xsession conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xsetup conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xwilling conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/backgroundrc conflicts between attempted installs
of kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/kdmrc conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7

Error Summary
-------------

#### ^^^ nothing here

Comment 1 Seth Vidal 2007-08-03 20:29:05 UTC
that's nice. Can you check out the latest version of yum in either f7 or in
rawhide and let me know if it is still happening?
reopen if it is - I'm pretty sure we closed this


Note You need to log in before you can comment on or make changes to this bug.