Bug 240539 - Anaconda fails to work with non-flat repositories
Anaconda fails to work with non-flat repositories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-18 07:54 EDT by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 11:34:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-05-18 07:54:09 EDT
Description of problem:

I've created a yum repository and attempted to tell anaconda to use it
during the package selection phase. I got an error like "Unable to fetch
repodata/comps.xml, No more mirrors to try" (or something similar). My
repository was layouted like this:

repository
    packages1
         *.rpm
    packages2
         *.rpm
    repodata
         *

As per tcpdump and webserver logs (the repository was accessible via http),
it seemed that anaconda downloaded the comps.xml correctly. When I changed
the layout to look like this, anaconda finally accepted the repository:

repository
     *.rpm
     repodata
          *

If this is a design issue, it would be at least nice to get a somewhat
better error message.
Comment 1 Jeremy Katz 2007-05-18 17:34:23 EDT
Did the repodata properly reference the packages under packages1/, etc?
Comment 2 Red Hat Bugzilla 2007-06-11 23:54:34 EDT
requested by Jams Antill
Comment 3 Lubomir Kundrak 2007-10-17 05:55:37 EDT
Jeremy: I did not use the fc6 anaconda with such repositories since I reported
this. Yesterday I installed Rawhide (the repodata created in Rawhide as well)
correctly with the repository laid as described above.
Comment 4 Chris Lumens 2007-10-26 11:34:04 EDT
If I understand comment #3 correctly, this is no longer an issue.  Feel free to
reopen this bug if you are continuing to see this problem, though.

Note You need to log in before you can comment on or make changes to this bug.