Bug 240542 - pirut is not accessible
pirut is not accessible
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-18 08:29 EDT by Alexander Todorov
Modified: 2013-04-12 15:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 16:25:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 163132 None None None Never

  None (edit)
Description Alexander Todorov 2007-05-18 08:29:39 EDT
Description of problem:
pirut does not export any accessible widgets when assistive technologies are
enabled.


Version-Release number of selected component (if applicable):
pirut-1.2.10-1.el5


How reproducible:
Assistive technologies must be enabled. Run pirut.


Steps to Reproduce:
1. Go to System->Preferences->Accessibility->Assistive Technologies Preferenes.
2. Enable assistive technologies
3. Log out
4. Log in again
5. Start pirut from Applications->Add/Remove Software
6. Install Dogtail and start the sniff utility
(Applications->Programming->AT-SPI Browser)
  
Actual results:
When using the sniff utility pirut shows no children. Other applications (e.g.
gaim, Firefox) show their accessible children.

Expected results:
pirut exports accessibility information and all children widgets are shown when
using the sniff utility.

Additional info:
Comment 1 Jeremy Katz 2007-05-22 15:29:11 EDT
Are you running sniff as root? 
Comment 2 Alexander Todorov 2007-05-23 03:45:01 EDT
I tested with 2 sniff instances. One running as root, other as regular user.
Start pirut from Applications->Add/Remove Software and fill in my root pw.
Start another gui application that needs root privileges (system-config-network).
Click refresh on both sniff instances.
Result:
non root sniff shows both applications (pirut & system-config-network) as not
accessible.
root sniff shows ONLY system-config-network as accessible. Does not show pirut.
Comment 3 Alexander Todorov 2007-05-23 03:49:07 EDT
Please see external bugzilla reference. I think it is related.
Comment 4 RHEL Product and Program Management 2008-07-21 19:11:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 Vladimir Benes 2008-07-28 04:23:21 EDT
Pirut is accessible but it has to be run as /usr/sbin/pirut because otherwise it
uses consolehelper which breaks accessibility (I have already filled a bug)

Note You need to log in before you can comment on or make changes to this bug.