Bug 240637 - yumex crash upon start
Summary: yumex crash upon start
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 240638 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-19 03:01 UTC by jakub
Modified: 2014-01-21 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 06:40:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jakub 2007-05-19 03:01:27 UTC
Description of problem:

cannot start yumex

Version-Release number of selected component (if applicable):
1.2.3

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Component: yumex
Version: 1.2.3
Summary: TB3638d33a ConfigParser.py:511:get:NoSectionError: No section: 'main'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1115, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 507, in __init__
    self.profile = Profile()
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 1202, in 
__init__
    self.active=self.profiles.get( "main", "LastProfile" )
  File "/usr/lib/python2.4/ConfigParser.py", line 511, in get
    raise NoSectionError(section)
NoSectionError: No section: 'main'

Local variables in innermost frame:
d: {}
vars: None
self: <ConfigParser.ConfigParser instance at 0x8ab6fec>
raw: False
section: main
option: LastProfile

Comment 1 Seth Vidal 2007-05-20 03:42:02 UTC
*** Bug 240638 has been marked as a duplicate of this bug. ***

Comment 2 Tim Lauridsen 2007-05-22 07:45:00 UTC
look like a problem with /etc/yumex.profiles.conf

Thy to replace the content of the file with this.

[main]
lastprofile = yum-enabled


Note You need to log in before you can comment on or make changes to this bug.