Bug 240654 - Unable to automount USB, CD, DVD (hal.permissiondenied)
Unable to automount USB, CD, DVD (hal.permissiondenied)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-19 09:12 EDT by Marius Andreiana
Modified: 2013-03-05 22:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 16:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The list of packages for update from pure F7t4 to the latest devel tree (43.36 KB, text/plain)
2007-05-30 04:39 EDT, Milan Kerslager
no flags Details

  None (edit)
Description Marius Andreiana 2007-05-19 09:12:38 EDT
Description of problem: Burnt dvd with k3b & closed it. Eject & insert dvd
always gives
Cannot mount volume
"Error org.freedesktop.Hal.PermissionDenied" Not in active session

How reproducible:
50% (it's not the 1st time this happens)
another report here
http://www.google.ro/search?q=+%22Error+org.freedesktop.Hal.PermissionDenied%22+active+session&btnG=C%C4%83utare&hl=ro&client=firefox-a&rls=org.mozilla%3Aen-US%3Aofficial&hs=Y9i
Comment 1 Milan Kerslager 2007-05-23 11:52:12 EDT
I'm still unable to mount USB, CD or DVD because permissin denied for HAL. This
 works under root account but not under normal user.

The system is up-to-date development tree (5/23/2007).

This seems that there is similar already closed bug #240654. It does not work
even SELinux in targeted and permissive mode.
Comment 2 Jakub Hrozek 2007-05-28 14:20:56 EDT
Milan, I think you meant bug #229465 :)

Anyway, I'm bitten by this, too, so I'm attaching a few (hopefully) relevant
pieces of information:

hal-0.5.9-8.fc7
ConsoleKit-0.2.1-2.fc7
gdm-2.18.0-14.fc7

* ConsoleKit service is running
* SELinux in permissive mode, but no avc denials in /var/log/messages
* $XDG_SESSION_COOKIE does not exist
* I'm logged via gdm

# cat /var/lib/hal/acl-list
/dev/adsp       u       42
/dev/audio      u       42
/dev/dsp        u       42
/dev/mixer      u       42
/dev/sequencer  u       42
/dev/sequencer2 u       42
/dev/snd/controlC0      u       42
/dev/snd/pcmC0D0c       u       42
/dev/snd/pcmC0D0p       u       42
/dev/snd/pcmC0D1p       u       42
/dev/snd/pcmC0D2c       u       42
/dev/snd/seq    u       42
/dev/snd/timer  u       42
Comment 3 Elvin E. Ebora 2007-05-29 03:08:25 EDT
I have the same problem. Here are my infos:

hal-0.5.9-8.fc7
ConsoleKit-0.2.1-2.fc7
gdm-2.18.0-14.fc7

I have disabled SELinux trying to see if this is an SELinux problem, but still
no success.

Before this automount feature works flawlessly (I think Test1 and Test2) until
last week when I was trying to backup my data using USB flash disk. I am up to
date with the latest releases.
Comment 4 Milan Kerslager 2007-05-30 04:35:13 EDT
Original Fedora 7 Test 4 does not have the problem so the bug is inside latest
devel tree change since F7t4 release.

I tryed to downgrade gdm and hal* packages to the versions from F7t4
(gdm-2.18.0-11.fc7, hal-0.5.9-5.fc7, ConsoleKit has not been changed since F7t4)
but it did not helped. Latest sync with current devel tree did not helped too.

I don't know what package may caused the problem with hal.permissiondenied.
Comment 5 Milan Kerslager 2007-05-30 04:39:02 EDT
Created attachment 155662 [details]
The list of packages for update from pure F7t4 to the latest devel tree

One of the package listed in the update list causes hal.permission denied
problem. But I don't know which of them... :-(
Comment 6 Milan Kerslager 2007-05-30 06:02:08 EDT
I tryed to downgrade gnome-session, gnome-vfs2, gnome-volume-manager and
notification-daemon with no luck.

The debug messages from HAL daemon:

11:08:37.156 [I] blockdev.c:127: Add callouts completed
udi=/org/freedesktop/Hal/devices/volume_label_Fryc_PC03
11:08:37.156 [I] hald.c:103: Added device to GDL;
udi=/org/freedesktop/Hal/devices/volume_label_Fryc_PC03
11:08:37.214 [W] ci-tracker.c:235: Error doing GetSessionForUnixProcess on
ConsoleKit: org.freedesktop.DBus.Error.ServiceUnknown: The name
org.freedesktop.ConsoleKit was not provided by any .service files
11:08:37.214 [I] hald_dbus.c:4477: Caller ':1.37' does not have access to device
'/org/freedesktop/Hal/devices/volume_label_Fryc_PC03'
Comment 7 David Zeuthen 2007-05-30 15:55:56 EDT
My guess is that gdm is the culprit. Does this work if you go to runlevel 3 (as
root: 'telinit 3'), log in on the console and startx? 
Comment 8 Milan Kerslager 2007-05-30 16:18:31 EDT
I solved the problem by running ConsoleKit daemon before HAL daemon (ie full
reboot instead start/stop cycles). So this was my fault, sorry.

The problem is that HAL daemon does not report more closely where the problem is
or does not suggest what I have to check. The second problem is that ConsoleKit
daemon died sometimes when I walked from runlevel 5 to 3 and back with
ConsoleKit start/stop (will try to reproduce and fill separate BZ).
Comment 9 David Zeuthen 2007-05-30 16:29:42 EDT
OK, so I can close this bug. (and yes, hald could use better error reporting)
Comment 10 Marius Andreiana 2007-05-30 17:00:39 EDT
How about the rest of the reporters who aren't using ConsoleKit? Don't think its
ok to close.
Since it's not 100% reproductible, I can't test without gdm. One could try
running without it for a few weeks and see if error still occurs to test..
Comment 11 David Zeuthen 2007-05-30 17:28:03 EDT
(In reply to comment #10)
> How about the rest of the reporters who aren't using ConsoleKit? Don't think its
> ok to close.

Uhm, hal requires ConsoleKit; it's not an option not to use it if you want to
use the hal built for Fedora.

> Since it's not 100% reproductible, I can't test without gdm. One could try
> running without it for a few weeks and see if error still occurs to test..

Yes, and as you correctly said that (e.g. CK crashing) should be filed against
ConsoleKit, not hal.
Comment 12 Marius Andreiana 2007-05-31 21:29:30 EDT
Thanks for reply David,

I didn't know about CK being pushed to us :)

Ok, so I have in rc.d:
$ ls *Cons*
S90ConsoleKit
$ ls *hal*
S98haldaemon
(I haven't made any changes to order), which fixes it for Milan but still
doesn't work for me sometimes. SElinux is disabled.

It's ok to leave this closed now. When it happens again for me, what information
should I save & provide?
Thanks
Comment 13 Milan Kerslager 2007-06-02 04:19:28 EDT
When you experience a problem, try run: /etc/init.d/ConsoleKit status
The console-kit-daemon should be running.

Note You need to log in before you can comment on or make changes to this bug.