Bug 240711 - running pirut as non-root user causes crash due to file permissions
Summary: running pirut as non-root user causes crash due to file permissions
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 01:48 UTC by Eric Harney
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.3.9-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 22:24:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pirut trace (2.39 KB, text/plain)
2007-05-21 01:48 UTC, Eric Harney
no flags Details

Description Eric Harney 2007-05-21 01:48:21 UTC
Description of problem:
Running pirut as a non-root user causes a crash if yum data has been cleaned and
not replaced

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
Every time

Steps to Reproduce:
1. # yum clean all   (as root)
2. $ pirut    (as user)
  
Actual results:
pirut crashes with a python dump due to permission errors, trying to create
/var/cache/yum/development/repomd.xml as a user

Additional info:
See attached stack trace from pirut

Comment 1 Eric Harney 2007-05-21 01:48:21 UTC
Created attachment 155066 [details]
pirut trace

Comment 2 Jeremy Katz 2007-05-22 19:43:16 UTC
Exception caught and given a bit more nicely as an error in CVS.  Won't make F7
final, but should then get pushed out in an update

Comment 3 Fedora Update System 2007-07-23 18:50:15 UTC
pirut-1.3.9-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2007-08-10 22:24:28 UTC
pirut-1.3.9-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.