Bug 240725 - "Crash" with database update failed
Summary: "Crash" with database update failed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 08:17 UTC by Benny Amorsen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: dhcp-3.0.5-38.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 15:24:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Benny Amorsen 2007-05-21 08:17:43 UTC
This morning I received many of these on one of my DHCP-servers:

May 21 05:36:08 dns01 dhcpd: Wrote 0 deleted host decls to leases file.
May 21 05:36:08 dns01 dhcpd: Wrote 0 new dynamic host decls to leases file.
May 21 05:36:08 dns01 dhcpd: Wrote 4691 leases to leases file.
May 21 05:36:10 dns01 dhcpd: DHCPREQUEST for 10.0.117.180 (172.31.0.12) from
00:04:13:24:14:ea (73) via bond0
May 21 05:36:10 dns01 dhcpd: DHCPACK on 10.0.117.180 to 00:04:13:24:14:ea (73)
via bond0
May 21 05:36:10 dns01 dhcpd: commit_leases: unable to commit: Bad file descriptor
May 21 05:36:10 dns01 dhcpd: DHCPREQUEST for 10.0.90.202 (172.31.0.12) from
00:04:13:24:76:48 (138) via bond0: database update failed
May 21 05:36:10 dns01 dhcpd: commit_leases: unable to commit: Bad file descriptor

The server failed to hand out any leases, and its failover peer didn't
take over. After a restart, the server started working normally again.

Both failover peers run dhcp-3.0.5-4.fc6 on Fedora Core 6.

The problem may be related to this:

May 21 04:17:24 dns01 dhcpd: timeout waiting for failover peer dhcp
May 21 04:17:24 dns01 dhcpd: failover peer dhcp: I move from normal to
communications-interrupted
May 21 04:17:29 dns01 dhcpd: failover peer dhcp: peer moves from normal to
communications-interrupted
May 21 04:17:29 dns01 dhcpd: failover peer dhcp: I move from
communications-interrupted to normal
May 21 04:17:29 dns01 dhcpd: failover peer dhcp: peer moves from
communications-interrupted to normal
May 21 04:17:58 dns01 dhcpd: failover: link startup timeout
May 21 04:17:58 dns01 dhcpd: Object 802f19c0 failover-link
May 21 04:17:59 dns01 dhcpd: timeout waiting for failover peer dhcp
May 21 04:17:59 dns01 dhcpd: failover peer dhcp: I move from normal to
communications-interrupted
May 21 04:18:03 dns01 dhcpd: failover peer dhcp: peer moves from normal to
communications-interrupted
May 21 04:18:03 dns01 dhcpd: failover peer dhcp: I move from
communications-interrupted to normal
May 21 04:18:03 dns01 dhcpd: failover peer dhcp: peer moves from
communications-interrupted to normal
May 21 04:21:30 dns01 dhcpd: timeout waiting for failover peer dhcp
May 21 04:21:30 dns01 dhcpd: failover peer dhcp: I move from normal to
communications-interrupted
May 21 04:21:35 dns01 dhcpd: failover peer dhcp: peer moves from normal to
communications-interrupted
May 21 04:21:35 dns01 dhcpd: failover peer dhcp: I move from
communications-interrupted to normal
May 21 04:21:35 dns01 dhcpd: failover peer dhcp: peer moves from
communications-interrupted to normal
May 21 04:21:45 dns01 dhcpd: failover: link startup timeout
May 21 04:21:45 dns01 dhcpd: Object 80171de0 failover-link
May 21 04:21:49 dns01 dhcpd: Failover CONNECTACK from 172.31.0.13: already connected
May 21 04:21:49 dns01 dhcpd: failover peer dhcp: peer moves from normal to
communications-interrupted
May 21 04:21:54 dns01 dhcpd: Failover CONNECTACK from 172.31.0.13: already connected
May 21 04:21:59 dns01 dhcpd: Failover CONNECTACK from 172.31.0.13: already connected
May 21 04:22:04 dns01 dhcpd: Failover CONNECTACK from 172.31.0.13: already connected
May 21 04:22:09 dns01 dhcpd: Failover CONNECTACK from 172.31.0.13: already connected
May 21 04:22:11 dns01 dhcpd: timeout waiting for failover peer dhcp
May 21 04:22:11 dns01 dhcpd: failover peer dhcp: I move from normal to
communications-interrupted
May 21 04:22:14 dns01 dhcpd: failover peer dhcp: peer moves from
communications-interrupted to communications-interrupted
May 21 04:22:14 dns01 dhcpd: failover peer dhcp: I move from
communications-interrupted to normal
May 21 04:22:14 dns01 dhcpd: failover peer dhcp: peer moves from
communications-interrupted to normal

Comment 1 David Cantrell 2007-08-15 21:40:56 UTC
Have you tried this on Fedora 7 Test 1 or a Fedora development tree?  I've
updated dhcp to 3.0.6, so I'm wondering if it's still happening.

Comment 2 Benny Amorsen 2007-08-16 15:19:35 UTC
The crash was a one-off thing, so I cannot tell if the problem is gone. Now
running dhcp-3.0.5-38.fc7 on F7, and so far no problems.

Comment 3 David Cantrell 2007-08-16 15:24:51 UTC
Thanks for the update.  Given that I can't reproduce locally, I'm going to mark
this as working in the current release.


Note You need to log in before you can comment on or make changes to this bug.