Bug 240752 - kernel dm io: panic on large request
Summary: kernel dm io: panic on large request
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.5
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 13:39 UTC by Milan Broz
Modified: 2013-03-01 04:05 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-11-15 16:27:26 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Milan Broz 2007-05-21 13:39:34 UTC
+++ This bug was initially created as a clone of Bug #240751 +++
RHEL 4.6. clone, reproducer script in bug 240751

Kernel will panic when creating ~6TB mirror because bio_alloc_bioset() will
return NULL if 'num_vecs' is too large.

Patch upstream
http://www.kernel.org/pub/linux/kernel/people/agk/patches/2.6/editing/dm-io-fix-panic-on-large-request.patch

Comment 1 RHEL Product and Program Management 2007-05-21 14:06:50 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Jason Baron 2007-07-03 22:50:52 UTC
committed in stream U6 build 55.16. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 7 errata-xmlrpc 2007-11-15 16:27:26 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.