Bug 240776 - diskboot.img fails to boot
Summary: diskboot.img fails to boot
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 16:25 UTC by Roderick Johnstone
Modified: 2013-01-10 01:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 03:33:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make pypungi spew to cli (753 bytes, patch)
2007-05-21 22:25 UTC, Jesse Keating
no flags Details | Diff

Description Roderick Johnstone 2007-05-21 16:25:31 UTC
Description of problem:
Cannot boot installer from diskboot.img

Version-Release number of selected component (if applicable):
Current rawhide

How reproducible:
Every time

Steps to Reproduce:
1. dd if=diskboot.img of=/dev/sda1 (writes diskboot.img to USB drive)
2. Configure PC to boot from USB
3. Boot PC
  
Actual results:
Gives: "This disk is not bootable disk ..." message

Expected results:
PC boots to installer.

Additional info:
Mounting diskboot.img on the loopback device shows an empty filesystem.

diskboot.img from test4 release works fine, and shows files when loopback mounted.

Comment 1 Jeremy Katz 2007-05-21 22:02:00 UTC
Things look fine when composed as an RC candidate with pungi; so something is
probably going wrong in the environment that rawhide is being built in.

Bill -- does the rawhide compose environment have loop devs?  Or where's a log
and I'll pore over it to see if I see why things are failing.

Comment 6 Jesse Keating 2007-05-21 22:25:26 UTC
Created attachment 155134 [details]
patch to make pypungi spew to cli

Comment 7 Jeremy Katz 2007-05-22 03:26:17 UTC
Definitely looks like the loopback mount isn't happening.  Bits are landing in
tree/images/fobpath -- that's where the image gets mounted in
scripts/mk-images.x86.  Log still doesn't have error messages, but I think
that's due to stderr being lost more than anything

Comment 8 Bill Nottingham 2007-05-22 03:33:02 UTC
Should be 'fixed' in the next build.


Note You need to log in before you can comment on or make changes to this bug.