Bug 240835 - Bad Provides interfere with Core and buildsys
Bad Provides interfere with Core and buildsys
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nx (Show other bugs)
6
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 03:58 EDT by Michael Schwendt
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.1.0-22.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 00:15:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-05-22 03:58:48 EDT
The FE6 and FE5 updates for "nx" and "freenx" have been withdrawn
after breaking the buildsys with unusable buildroots. See thread on
fedora-maintainers list. It is likely that some users have updated
to the packages already in the few hours they have been available
in the repo.

$ rpm -qp --provides nx-2.1.0-19.fc6.i386.rpm 
libX11.so.6  
libXcomp.so.2  
libXcompext.so.2  
libXext.so.6  
libXrender.so.1  
nx = 2.1.0-19.fc6

These Provides interfere with the X Window System packages and
sonames.
Comment 1 Axel Thimm 2007-05-22 05:23:04 EDT
Thats ugly, thanks for reporting. I'll try to get a fix in asap.
Comment 2 Axel Thimm 2007-05-23 06:37:47 EDT
Should now be fixed in the packages in the queue.
Comment 3 Michael Schwendt 2007-05-23 06:56:23 EDT
Why don't you also filter out the

  libXcomp.so.2  
  libXcompext.so.2  

Provides? The libs are located outside dynamic linker's search path,
so any program which would, e.g., "Requires: libXcomp.so.2" would not
be satisfied by installed "nx".

Further, contrary to i386/ppc, the x86_64 pkg does not provide these
sonames:

$ rpm -qp --provides nx-2.1.0-21.fc6.x86_64.rpm 
nx = 2.1.0-21.fc6
Comment 4 Axel Thimm 2007-05-23 07:31:55 EDT
(In reply to comment #3)
> Why don't you also filter out the
> 
>   libXcomp.so.2  
>   libXcompext.so.2  

There are needed by other components. The reason some libs need to be filtered
out is because they overlap with the standard X11 libs, these don't exist (yet)
in X11.

It's either that, or filtering Requires as well.
Comment 5 Michael Schwendt 2007-05-23 11:29:45 EDT
Ouch, that sounds broken.

$ rpm -qpR nx-2.1.0-21.fc6.i386.rpm |grep libX
libX11.so.6  
libXaw.so.7  
libXcomp.so.2  
libXcompext.so.2  
libXext.so.6  
libXmu.so.6  
libXpm.so.4  
libXrender.so.1  
libXt.so.6  

[...]

And it doesn't explain what's wrong with the x86_64 packaging.
Look! The Requires are completely gone and hence broken:

$ rpm -qpR nx-2.1.0-21.fc6.x86_64.rpm 
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Comment 6 Axel Thimm 2007-05-23 11:48:39 EDT
Why does that sound broken? FWIW it is exactly the same situation as the
previous package

# rpm -qRp nx-2.1.0-1.fc6.i386.rpm | grep libX
libX11.so.6  
libXaw.so.7  
libXcomp.so.2  
libXcompext.so.2  
libXext.so.6  
libXmu.so.6  
libXpm.so.4  
libXrender.so.1  
libXt.so.6  

The x86_64 packages do look suspicous. BTW how does one access them while not
yet pushed out?
Comment 7 Michael Schwendt 2007-05-23 12:03:37 EDT
http://buildsys.fedoraproject.org/plague-results/

[...]

Your package requires SONAMEs of libraries, which are included in the
package itself (with the corresponding Provides being filtered), but
which are provided only by external libX* packages instead. There is
a mismatch between what is required and what is pulled in.

Either the included libraries are needed, and then the package
ought not require external X library sonames. Or the included libraries
are not needed, and then the package ought not include them at all.
Comment 8 Axel Thimm 2007-05-23 12:25:32 EDT
[... /plague-results/]: Thanks, that's a nice service, I wasn't aware of that
(maybe worth making more visible somewhere in the wiki).

On the packages' Provides/Requires: The packages does need the own-supplied
sonames (at least as long as it is a mega-package as it is now). The reason for
filtering out some of them is due to other unrelated packages pulling this
package in instead of the canonical X11 packages. A better upstream solution
would had been to change the sonames (really *change*, not just bump), but they
didn't and I don't want to play my own tune here.
Comment 9 Michael Schwendt 2007-05-23 14:08:07 EDT
You only repeat what the opening comment of this ticket says.
Remember, pollution of the global soname namespace was the
reason for this ticket. I'm fully aware of what's wrong with
the package.

> The packages does need the own-supplied sonames

Sure it does. It uses LD_LIBRARY_PATH to modify the dynamic
linker's search path. But it has a dependency on external library
sonames. I wanted to point that out, I don't care whether it will
be fixed/improved.

[...]

But are you even sure the package works? nxwrapper here contains
an unreplaced substitution variable @PKGEXECDIR@. 
Comment 10 Axel Thimm 2007-05-23 14:57:47 EDT
> You only repeat what the opening comment of this ticket says.

Well, if everything is known by all sides, then we don't have to discuss
anything further. :)

On nxwrapper: Yes, you found a bug there, but no, it does not affect the core
package functionality (e.g. being used for an nx server with freenx for example).

But it needs to be fixed, of course, thanks for pointing that out!
Comment 11 Michael Schwendt 2007-05-31 05:59:14 EDT
Bottom part of comment 5 still holds true when I had a look last night.
Comment 12 Axel Thimm 2007-05-31 19:03:02 EDT
No, this is long fixed, but it seems like no one wants to push the package.
Maybe once the F7 dust settles people will check the queues again.
Comment 13 Michael Schwendt 2007-05-31 19:08:16 EDT
$ rpm -qpR nx-2.1.0-21.1.fc6.x86_64.rpm 
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

[mschwendt@extras64 x86_64]$ date
Thu May 31 19:07:43 EDT 2007
Comment 14 Axel Thimm 2007-05-31 19:49:37 EDT
Interesting, a local build yields

# rpm -qpR nx-2.1.0-21.1.fc6.x86_64.rpm
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/sh  
libICE.so.6()(64bit)  
libSM.so.6()(64bit)  
libX11.so.6()(64bit)  
libXaw.so.7()(64bit)  
libXcomp.so.2()(64bit)  
libXcompext.so.2()(64bit)  
libXext.so.6()(64bit)  

Comment 15 Axel Thimm 2007-05-31 20:07:19 EDT
I found a missing fix in the Fedora CVS (was only in devel), so I hope that -22
will look like ATrpms' 21.1.
Comment 16 Fedora Update System 2007-06-04 00:15:55 EDT
nx-2.1.0-22.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.