Bug 240921 - Versions of LVM2 from 4.5 are equal or greater then 5.0 versions.
Versions of LVM2 from 4.5 are equal or greater then 5.0 versions.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 17:22 EDT by Gavin
Modified: 2007-11-16 20:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 17:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin 2007-05-22 17:22:16 EDT
Description of problem:
When trying to upgrade lvm2 rpm from a 4.5 base this fails because the version 
in 4.5 are equal or greater than 5.0...

ftp://ftp.redhat.com/pub/redhat/linux/updates/enterprise/4AS/en/os/SRPMS/lvm2-
2.02.21-5.el4.src.rpm
http://mirrors.kernel.org/redhat/redhat/linux/enterprise/5Server/en/os/SRPMS/lv
m2-2.02.16-3.el5.src.rpm

The above shows the 2 different versions, it seems the version numbers have 
jumped
Comment 1 Alasdair Kergon 2007-05-22 17:54:15 EDT
The packages leapfrog ahead of each other because the freeze dates for the
distro updates are different.  Higher version is newer - so your RHEL4.5 package
is newer and better.  (Read the changelog.)

If you're building from source and not doing anything where the base distros
differ in significant ways (e.g. some lvm2-cluster extensions, lvm2 mirroring,
selinux policy changes) the 4.5 package should be fine on RHEL5.

Note You need to log in before you can comment on or make changes to this bug.