This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 240930 - Unable to format a floppy in a USB drive
Unable to format a floppy in a USB drive
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 21:11 EDT by Chris Adams
Modified: 2008-04-04 09:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 09:05:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2007-05-22 21:11:39 EDT
It does not appear possible to format a floppy in a USB floppy drive.  fdformat
wants /dev/fd0[format] and floppy wants an /etc/floppy config file (which
doesn't appear to work anyway, but doesn't really work in a hotplug environment).
Comment 1 Karel Zak 2007-05-23 04:48:26 EDT
Please, provide more details about your USB floppy device. I asuume that the
device is visible as a scsi device (/dev/sd...), right?

I found two interesting things:
  http://lkml.org/lkml/2006/11/19/51
  http://www.geocities.jp/tedi_world/format_usbfdd_e.html

Comment 2 Chris Adams 2007-07-21 23:21:34 EDT
Yes, it is /dev/sdX (depends on what other USB stuff is plugged in).  With the
right udev rules, it shows up as /dev/floppy and /dev/floppy-sdX.

I tried the ufiformat from the second link and it appears to work.  It'd be nice
to see that in Fedora.
Comment 3 Bug Zapper 2008-04-04 03:16:44 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Chris Adams 2008-04-04 09:05:47 EDT
This isn't a bug in the fdformat command, it is something that has to be solved
with another package.  I have packaged and submitted ufiformat for review (also
my first package so I'll need a sponsor before it goes in).

Note You need to log in before you can comment on or make changes to this bug.