This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 24094 - nVidia driver comp with 2.4.x kernel rawhide gives errors
nVidia driver comp with 2.4.x kernel rawhide gives errors
Status: CLOSED DUPLICATE of bug 23946
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-16 00:59 EST by Jeff Lane
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-22 10:53:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Lane 2001-01-16 00:59:49 EST
I am posting this for a customer. 

SYSTEM CONFIG:
  Pii 300/Intel Atlanta Motherboard/256MB/Creative Labs TNT
  RH7 with all updates and rawhide kernel rpms (2.4.0-0.43.12)

  STEPS TO DUPLICATE SYMPTOM
  1) download .95 drivers
 
ftp1.detonator.nvidia.com/pub/drivers/english/XFree86_40/0.9-5/NVIDIA_kernel-0.9-5.tar.gz

  2) download patch to make driver work with 2.4:
  http://www.linuxgames.com/misc/patch-2.4.0-PR

  3)untar the source tarball:
  tar xvzf NVIDIA_kernel-0.9-5.tar.gz

  4)apply the patch:
  patch -p1 <~/patch-2.4.0-PR

  5)make the module:
  make

  ERROR REPORTED:
  modprobe NVdriver
  /lib/modules/2.4.0-0.43.12/video/NVdriver: unresolved symbol irq_stat
  /lib/modules/2.4.0-0.43.12/video/NVdriver: insmod
  /lib/modules/2.4.0-0.43.12/video/NVdriver failed
  /lib/modules/2.4.0-0.43.12/video/NVdriver: insmod NVdriver failed

  COMMENTS
  Any ideas? If I use virgin kernel sources from kernel.org, then this
patch
  works fine. This is something from rh kernel .rpms I'm not a C guy or I
  would probably be able to fix this quickly. Any help would be appreciated
Comment 1 Jeff Lane 2001-01-16 01:02:31 EST
I posted this because the customer commented that this patch DOES work with the
stock kernel from kernel.org, and does NOT work with the rawhide kernel.
Comment 2 Sammy 2001-01-16 12:56:01 EST
I found out that if you add -D__module__i686_up into the DEFINES line in
your Makefile everything compiles fine and I have been running it for two
days.....I have no idea why!
Comment 3 Sammy 2001-01-22 10:52:58 EST
Also......NVIDIA just announced new drivers (0.96) for 2.4 and RH7 etc....
They compile and work fine.
Comment 4 Mike A. Harris 2002-02-11 02:57:53 EST

*** This bug has been marked as a duplicate of 23946 ***

Note You need to log in before you can comment on or make changes to this bug.