Bug 240940 - [Tray ICON] Left Click->Selecting 'Laptop Battery' Shows Nothing
[Tray ICON] Left Click->Selecting 'Laptop Battery' Shows Nothing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
bzcl34nup
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-23 04:23 EDT by A S Alam
Modified: 2013-07-02 20:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 22:45:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2007-05-23 04:23:02 EDT
Description of problem:
[Tray ICON] Left Click->Selecting 'Laptop Battery' Shows Nothing.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.19.2-1.fc8
libnotify-0.4.4-2.fc7
notification-daemon-0.3.7-2.fc7

How reproducible:
Everytime during selection of Laptop Battery

Steps to Reproduce:
1. Left Click on g-p-m's ICON
2. Select 'LAptop Battery'
3. 
  
Actual results:
Nothing appear on screen

Expected results:
Information (Notification) should be there

Additional info:
Comment 1 Richard Hughes 2007-05-23 05:47:27 EDT
If you run:

killall gnome-power-manager
gnome-power-manager --verbose --no-daemon

and then click on Laptop battery, what is the debugging output? Thanks.
Comment 2 A S Alam 2007-05-23 06:07:15 EDT
aalam@alamPunjabi ~]$ gnome-power-manager --verbose --no-daemon
[gpm_debug_init] gpm-debug.c:238 (15:31:32):     Verbose debugging enabled
[main] gpm-main.c:209 (15:31:32):        GNOME Power Manager 2.19.2
[gpm_ac_adapter_init] gpm-ac-adapter.c:217 (15:31:32):   using
/org/freedesktop/Hal/devices/acpi_AC
[coldplug_buttons] gpm-button.c:441 (15:31:32):  Watching
/org/freedesktop/Hal/devices/computer_logicaldev_input_2
[coldplug_buttons] gpm-button.c:441 (15:31:32):  Watching
/org/freedesktop/Hal/devices/computer_logicaldev_input_1
[coldplug_buttons] gpm-button.c:441 (15:31:32):  Watching
/org/freedesktop/Hal/devices/computer_logicaldev_input_0
[coldplug_buttons] gpm-button.c:441 (15:31:32):  Watching
/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input
[gpm_control_init] gpm-control.c:617 (15:31:32):         Using a supressed
policy timeout of 5 seconds

** (gnome-power-manager:4869): WARNING **: DBUS error: Could not get owner of
name 'org.gnome.ScreenSaver': no such name
** (gnome-power-manager:4869): DEBUG: proxy is NULL, maybe the daemon
responsible for org.gnome.ScreenSaver is not running?
*** WARNING ***
[gpm_screensaver_proxy_connect_more] gpm-screensaver.c:107 (15:31:32):   not
connected
[gpm_brightness_lcd_init] gpm-brightness-lcd.c:594 (15:31:32):   Laptop panel
levels: 1

(gnome-power-manager:4869): GLib-GObject-CRITICAL **: g_value_set_int: assertion
`G_VALUE_HOLDS_INT (value)' failed
[gpm_brightness_lcd_get_hw] gpm-brightness-lcd.c:120 (15:31:32):        
GetBrightness returned level: 0
[gpm_brightness_lcd_init] gpm-brightness-lcd.c:610 (15:31:32):   current hw
brightness: 0
[gpm_brightness_lcd_init] gpm-brightness-lcd.c:617 (15:31:32):   Starting: (0 of 0)
[gpm_brightness_lcd_dim_hw] gpm-brightness-lcd.c:271 (15:31:32):        
new_level_hw=0
[gpm_brightness_lcd_dim_hw_step] gpm-brightness-lcd.c:202 (15:31:32):   
new_level_hw=0, current_hw=0
[gpm_brightness_lcd_set_dim] gpm-brightness-lcd.c:311 (15:31:32):        Current
brightness is 0, dim brightness is 0, so we'll use the current as the dim
brightness.
[gpm_feedback_set_icon_name] gpm-feedback-widget.c:107 (15:31:32):       Using
icon name 'gpm-brightness-lcd'
[gpm_backlight_sync_policy] gpm-backlight.c:151 (15:31:32):      choosing
sensible default
[gpm_backlight_sync_policy] gpm-backlight.c:153 (15:31:32):      laptop, so use
GPM_DPMS_METHOD_OFF
[gpm_backlight_sync_policy] gpm-backlight.c:185 (15:31:32):      BACKLIGHT
parameters 0 0 1800, method '4'
[gpm_dpms_set_enabled] gpm-dpms.c:408 (15:31:32):        setting DPMS enabled: 1
[x11_sync_server_dpms_settings] gpm-dpms.c:130 (15:31:32):       Syncing DPMS
settings enabled=1 timeouts=0 0 0
[x11_sync_server_dpms_settings] gpm-dpms.c:130 (15:31:32):       Syncing DPMS
settings enabled=1 timeouts=0 0 0
[gpm_idle_set_check_cpu] gpm-idle.c:236 (15:31:32):      Setting the CPU load
check to 0
[gpm_manager_init] gpm-manager.c:1598 (15:31:32):        creating new inhibit
instance
[gpm_manager_init] gpm-manager.c:1606 (15:31:32):        creating new control
instance
[gpm_manager_init] gpm-manager.c:1611 (15:31:32):        creating new tray icon
[gpm_manager_init] gpm-manager.c:1620 (15:31:32):        initialising info
infrastructure
[gpm_profile_init] gpm-profile.c:707 (15:31:32):         on AC
[gpm_idle_set_system_timeout] gpm-idle.c:287 (15:31:32):         Setting system
idle timeout: 0
[gpm_warning_init] gpm-warning.c:262 (15:31:32):         Using per-time
notification policy
[gpm_check_device_key] gpm-cell-array.c:676 (15:31:32):  checking primary
against primary
[gpm_cell_array_add] gpm-cell-array.c:748 (15:31:32):    adding the right kind
of battery: primary
[gpm_cell_unit_print] gpm-cell-unit.c:65 (15:31:32):     device         Laptop
battery
[gpm_cell_unit_print] gpm-cell-unit.c:66 (15:31:32):     present        1
[gpm_cell_unit_print] gpm-cell-unit.c:67 (15:31:32):     percent        100
[gpm_cell_unit_print] gpm-cell-unit.c:68 (15:31:32):     is charging    0
[gpm_cell_unit_print] gpm-cell-unit.c:69 (15:31:32):     is discharging 0
[gpm_cell_unit_print] gpm-cell-unit.c:71 (15:31:32):     charge current 46764
[gpm_cell_unit_print] gpm-cell-unit.c:74 (15:31:32):     charge last    46764
[gpm_cell_unit_print] gpm-cell-unit.c:77 (15:31:32):     charge design  52170
[gpm_cell_unit_print] gpm-cell-unit.c:89 (15:31:32):     capacity       89
[gpm_cell_unit_print] gpm-cell-unit.c:92 (15:31:32):     voltage        12584
[gpm_profile_set_config_id] gpm-profile.c:593 (15:31:32):        config_id = 1133
[gpm_profile_load_data] gpm-profile.c:544 (15:31:32):    loading battery data
from '/home/aalam/.gnome2/gnome-power-manager/profile-1133-discharging.csv'
[gpm_profile_load_data] gpm-profile.c:544 (15:31:32):    loading battery data
from '/home/aalam/.gnome2/gnome-power-manager/profile-1133-charging.csv'
[gpm_profile_set_config_id] gpm-profile.c:612 (15:31:32):        Reference times
[gpm_profile_set_config_id] gpm-profile.c:614 (15:31:32):        99-0   0 minutes
[gpm_profile_set_config_id] gpm-profile.c:616 (15:31:32):        50-0   0 minutes
[gpm_profile_set_config_id] gpm-profile.c:619 (15:31:32):        0-99   0 minutes
[gpm_profile_set_config_id] gpm-profile.c:621 (15:31:32):        50-99  0 minutes
[gpm_cell_array_update] gpm-cell-array.c:340 (15:31:32):         1 devices of
type primary
[gpm_cell_array_update] gpm-cell-array.c:386 (15:31:32):        
unit->percentage = 100
[gpm_profile_get_time] gpm-profile.c:250 (15:31:32):     percentage = 100,
correcting to 99
[gpm_profile_get_time] gpm-profile.c:250 (15:31:32):     percentage = 100,
correcting to 99
[gpm_cell_array_collection_changed] gpm-cell-array.c:710 (15:31:32):     **
EMIT: collection-changed
[gpm_engine_recalculate_state] gpm-engine.c:599 (15:31:32):      ignoring due to
coldplug
[gpm_cell_array_percent_changed] gpm-cell-array.c:482 (15:31:32):       
printing combined new device:
[gpm_cell_unit_print] gpm-cell-unit.c:65 (15:31:32):     device         Laptop
battery
[gpm_cell_unit_print] gpm-cell-unit.c:66 (15:31:32):     present        1
[gpm_cell_unit_print] gpm-cell-unit.c:67 (15:31:32):     percent        100
[gpm_cell_unit_print] gpm-cell-unit.c:68 (15:31:32):     is charging    0
[gpm_cell_unit_print] gpm-cell-unit.c:69 (15:31:32):     is discharging 0
[gpm_cell_unit_print] gpm-cell-unit.c:71 (15:31:32):     charge current 46764
[gpm_cell_unit_print] gpm-cell-unit.c:74 (15:31:32):     charge last    46764
[gpm_cell_unit_print] gpm-cell-unit.c:77 (15:31:32):     charge design  52170
[gpm_cell_unit_print] gpm-cell-unit.c:92 (15:31:32):     voltage        12584
[gpm_cell_array_percent_changed] gpm-cell-array.c:512 (15:31:32):        No warning
[gpm_cell_array_update] gpm-cell-array.c:340 (15:31:32):         1 devices of
type primary
[gpm_cell_array_update] gpm-cell-array.c:386 (15:31:32):        
unit->percentage = 100
[gpm_profile_get_time] gpm-profile.c:250 (15:31:32):     percentage = 100,
correcting to 99
[gpm_profile_get_time] gpm-profile.c:250 (15:31:32):     percentage = 100,
correcting to 99
[gpm_check_device_key] gpm-cell-array.c:676 (15:31:32):  checking primary
against ups
[gpm_cell_array_add] gpm-cell-array.c:736 (15:31:32):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for ups
[gpm_cell_array_update] gpm-cell-array.c:273 (15:31:32):         no devices of
type 1
[gpm_check_device_key] gpm-cell-array.c:676 (15:31:32):  checking primary
against mouse
[gpm_cell_array_add] gpm-cell-array.c:736 (15:31:32):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for mouse
[gpm_cell_array_update] gpm-cell-array.c:273 (15:31:32):         no devices of
type 2
[gpm_check_device_key] gpm-cell-array.c:676 (15:31:32):  checking primary
against keyboard
[gpm_cell_array_add] gpm-cell-array.c:736 (15:31:32):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for keyboard
[gpm_cell_array_update] gpm-cell-array.c:273 (15:31:32):         no devices of
type 3
[gpm_check_device_key] gpm-cell-array.c:676 (15:31:32):  checking primary
against pda
[gpm_cell_array_add] gpm-cell-array.c:736 (15:31:32):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for pda
[gpm_cell_array_update] gpm-cell-array.c:273 (15:31:32):         no devices of
type 4
[gpm_engine_get_icon] gpm-engine.c:366 (15:31:32):       Trying CRITICAL icon:
primary, ups, mouse, keyboard
*** WARNING ***
[gpm_warning_get_state_time] gpm-warning.c:85 (15:31:32):        time zero,
something's gone wrong
*** WARNING ***
[gpm_warning_get_state_percentage] gpm-warning.c:104 (15:31:32):        
percentage zero, something's gone wrong
[gpm_engine_get_icon] gpm-engine.c:390 (15:31:32):       Trying CHARGING icon:
primary, ups
[gpm_engine_get_icon] gpm-engine.c:407 (15:31:32):       Trying PRESENT icon:
primary, ups
[gpm_cell_unit_get_icon] gpm-cell-unit.c:199 (15:31:32):         got filename:
gpm-primary-charged
[gpm_engine_recalculate_state_icon] gpm-engine.c:530 (15:31:32):         **
EMIT: icon-changed: gpm-primary-charged
[gpm_tray_icon_set_icon] gpm-tray-icon.c:177 (15:31:32):         Setting icon to
gpm-primary-charged
[gpm_profile_get_accuracy] gpm-profile.c:647 (15:31:32):         corrected
percentage...
[gpm_cell_array_get_description] gpm-cell-array.c:905 (15:31:32):       
accuracy = 0
[gpm_profile_get_accuracy] gpm-profile.c:647 (15:31:32):         corrected
percentage...
[gpm_engine_get_summary] gpm-engine.c:328 (15:31:32):    tooltip: Computer is
running on AC power
Laptop battery fully charged (100%)
Battery charge profile is estimated
[gpm_engine_recalculate_state_summary] gpm-engine.c:570 (15:31:32):      **
EMIT: summary-changed(1): Computer is running on AC power
Laptop battery fully charged (100%)
Battery charge profile is estimated



[gpm_tray_icon_popup_menu_cb] gpm-tray-icon.c:440 (15:31:43):    icon right clicked
[gpm_tray_icon_popup_cleared_cd] gpm-tray-icon.c:365 (15:31:46):         clear
tray (icon = 0x94feeb8)
[gpm_tray_icon_activate_cb] gpm-tray-icon.c:560 (15:31:47):      icon left clicked
[gpm_tray_icon_add_device] gpm-tray-icon.c:521 (15:31:47):       adding device '0'
[gpm_cell_unit_get_icon] gpm-cell-unit.c:199 (15:31:47):         got filename:
gpm-primary-charged
[gpm_tray_icon_popup_cleared_cd] gpm-tray-icon.c:365 (15:31:48):         clear
tray (icon = 0x94feeb8)
[gpm_cell_unit_get_icon] gpm-cell-unit.c:199 (15:31:48):         got filename:
gpm-primary-charged
[gpm_notify_create] gpm-notify.c:127 (15:31:48):         libnotify: Power
Manager : <b>Product:</b> Battery Bay
<b>Status:</b> Charged
<b>Percentage charge:</b> 100%
<b>Vendor:</b> Panasonic
<b>Technology:</b> Lithium ion
<b>Serial number:</b> 1133
<b>Model:</b> DELL CC1546
<b>Capacity:</b> 89% (Fair)
<b>Current charge:</b> 46.8 Wh
<b>Last full charge:</b> 46.8 Wh
<b>Design charge:</b> 52.2 Wh
*** WARNING ***
[gpm_notify_show] gpm-notify.c:140 (15:31:49):   failed to send notification
      
Comment 3 Richard Hughes 2007-05-23 06:26:32 EDT
>[gpm_notify_show] gpm-notify.c:140 (15:31:49):   failed to send notification

is notification-daemon running in your session? Test with "notify-send moo" and
see if you get a notification.

Comment 4 A S Alam 2007-05-23 06:50:27 EDT
I was using it in KDE, but on my desktop only
with above also, got nothing
Comment 5 Richard Hughes 2007-05-23 06:52:17 EDT
It looks like KDE needs to start notification-daemon at startup.
Comment 6 A S Alam 2007-05-23 07:11:21 EDT
ok, now  with GNOME desktop:
------------
[aalam@alamPunjabi ~]$ gnome-power-manager --verbose --no-daemon
[gpm_debug_init] gpm-debug.c:238 (16:39:20):     Verbose debugging enabled
[main] gpm-main.c:209 (16:39:20):        GNOME Power Manager 2.19.2
[gpm_ac_adapter_init] gpm-ac-adapter.c:217 (16:39:20):   using
/org/freedesktop/Hal/devices/acpi_AC
[coldplug_buttons] gpm-button.c:441 (16:39:20):  Watching
/org/freedesktop/Hal/devices/computer_logicaldev_input_2
[coldplug_buttons] gpm-button.c:441 (16:39:20):  Watching
/org/freedesktop/Hal/devices/computer_logicaldev_input_1
[coldplug_buttons] gpm-button.c:441 (16:39:20):  Watching
/org/freedesktop/Hal/devices/computer_logicaldev_input_0
[coldplug_buttons] gpm-button.c:441 (16:39:20):  Watching
/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input
[gpm_control_init] gpm-control.c:617 (16:39:20):         Using a supressed
policy timeout of 5 seconds
[gpm_brightness_lcd_init] gpm-brightness-lcd.c:594 (16:39:20):   Laptop panel
levels: 1

(gnome-power-manager:6349): GLib-GObject-CRITICAL **: g_value_set_int: assertion
`G_VALUE_HOLDS_INT (value)' failed
[gpm_brightness_lcd_get_hw] gpm-brightness-lcd.c:120 (16:39:20):        
GetBrightness returned level: 0
[gpm_brightness_lcd_init] gpm-brightness-lcd.c:610 (16:39:20):   current hw
brightness: 0
[gpm_brightness_lcd_init] gpm-brightness-lcd.c:617 (16:39:20):   Starting: (0 of 0)
[gpm_brightness_lcd_dim_hw] gpm-brightness-lcd.c:271 (16:39:20):        
new_level_hw=0
[gpm_brightness_lcd_dim_hw_step] gpm-brightness-lcd.c:202 (16:39:20):   
new_level_hw=0, current_hw=0
[gpm_brightness_lcd_set_dim] gpm-brightness-lcd.c:311 (16:39:20):        Current
brightness is 0, dim brightness is 0, so we'll use the current as the dim
brightness.
[gpm_feedback_set_icon_name] gpm-feedback-widget.c:107 (16:39:20):       Using
icon name 'gpm-brightness-lcd'
[gpm_backlight_sync_policy] gpm-backlight.c:151 (16:39:20):      choosing
sensible default
[gpm_backlight_sync_policy] gpm-backlight.c:153 (16:39:20):      laptop, so use
GPM_DPMS_METHOD_OFF
[gpm_backlight_sync_policy] gpm-backlight.c:185 (16:39:20):      BACKLIGHT
parameters 0 0 1800, method '4'
[gpm_dpms_set_enabled] gpm-dpms.c:408 (16:39:20):        setting DPMS enabled: 1
[x11_sync_server_dpms_settings] gpm-dpms.c:130 (16:39:20):       Syncing DPMS
settings enabled=1 timeouts=0 0 0
[x11_sync_server_dpms_settings] gpm-dpms.c:130 (16:39:20):       Syncing DPMS
settings enabled=1 timeouts=0 0 0
[gpm_idle_set_check_cpu] gpm-idle.c:236 (16:39:20):      Setting the CPU load
check to 0
[gpm_manager_init] gpm-manager.c:1598 (16:39:20):        creating new inhibit
instance
[gpm_manager_init] gpm-manager.c:1606 (16:39:20):        creating new control
instance
[gpm_manager_init] gpm-manager.c:1611 (16:39:20):        creating new tray icon
[gpm_manager_init] gpm-manager.c:1620 (16:39:20):        initialising info
infrastructure
[gpm_profile_init] gpm-profile.c:707 (16:39:20):         on AC
[gpm_idle_set_system_timeout] gpm-idle.c:287 (16:39:20):         Setting system
idle timeout: 0
[gpm_warning_init] gpm-warning.c:262 (16:39:20):         Using per-time
notification policy
[gpm_check_device_key] gpm-cell-array.c:676 (16:39:20):  checking primary
against primary
[gpm_cell_array_add] gpm-cell-array.c:748 (16:39:20):    adding the right kind
of battery: primary
[gpm_cell_unit_print] gpm-cell-unit.c:65 (16:39:20):     device         Laptop
battery
[gpm_cell_unit_print] gpm-cell-unit.c:66 (16:39:20):     present        1
[gpm_cell_unit_print] gpm-cell-unit.c:67 (16:39:20):     percent        100
[gpm_cell_unit_print] gpm-cell-unit.c:68 (16:39:20):     is charging    0
[gpm_cell_unit_print] gpm-cell-unit.c:69 (16:39:20):     is discharging 0
[gpm_cell_unit_print] gpm-cell-unit.c:71 (16:39:20):     charge current 46764
[gpm_cell_unit_print] gpm-cell-unit.c:74 (16:39:20):     charge last    46764
[gpm_cell_unit_print] gpm-cell-unit.c:77 (16:39:20):     charge design  52170
[gpm_cell_unit_print] gpm-cell-unit.c:89 (16:39:20):     capacity       89
[gpm_cell_unit_print] gpm-cell-unit.c:92 (16:39:20):     voltage        12584
[gpm_profile_set_config_id] gpm-profile.c:593 (16:39:20):        config_id = 1133
[gpm_profile_load_data] gpm-profile.c:544 (16:39:20):    loading battery data
from '/home/aalam/.gnome2/gnome-power-manager/profile-1133-discharging.csv'
[gpm_profile_load_data] gpm-profile.c:544 (16:39:20):    loading battery data
from '/home/aalam/.gnome2/gnome-power-manager/profile-1133-charging.csv'
[gpm_profile_set_config_id] gpm-profile.c:612 (16:39:20):        Reference times
[gpm_profile_set_config_id] gpm-profile.c:614 (16:39:20):        99-0   0 minutes
[gpm_profile_set_config_id] gpm-profile.c:616 (16:39:20):        50-0   0 minutes
[gpm_profile_set_config_id] gpm-profile.c:619 (16:39:20):        0-99   0 minutes
[gpm_profile_set_config_id] gpm-profile.c:621 (16:39:20):        50-99  0 minutes
[gpm_cell_array_update] gpm-cell-array.c:340 (16:39:20):         1 devices of
type primary
[gpm_cell_array_update] gpm-cell-array.c:386 (16:39:20):        
unit->percentage = 100
[gpm_profile_get_time] gpm-profile.c:250 (16:39:20):     percentage = 100,
correcting to 99
[gpm_profile_get_time] gpm-profile.c:250 (16:39:20):     percentage = 100,
correcting to 99
[gpm_cell_array_collection_changed] gpm-cell-array.c:710 (16:39:20):     **
EMIT: collection-changed
[gpm_engine_recalculate_state] gpm-engine.c:599 (16:39:20):      ignoring due to
coldplug
[gpm_cell_array_percent_changed] gpm-cell-array.c:482 (16:39:20):       
printing combined new device:
[gpm_cell_unit_print] gpm-cell-unit.c:65 (16:39:20):     device         Laptop
battery
[gpm_cell_unit_print] gpm-cell-unit.c:66 (16:39:20):     present        1
[gpm_cell_unit_print] gpm-cell-unit.c:67 (16:39:20):     percent        100
[gpm_cell_unit_print] gpm-cell-unit.c:68 (16:39:20):     is charging    0
[gpm_cell_unit_print] gpm-cell-unit.c:69 (16:39:20):     is discharging 0
[gpm_cell_unit_print] gpm-cell-unit.c:71 (16:39:20):     charge current 46764
[gpm_cell_unit_print] gpm-cell-unit.c:74 (16:39:20):     charge last    46764
[gpm_cell_unit_print] gpm-cell-unit.c:77 (16:39:20):     charge design  52170
[gpm_cell_unit_print] gpm-cell-unit.c:92 (16:39:20):     voltage        12584
[gpm_cell_array_percent_changed] gpm-cell-array.c:512 (16:39:20):        No warning
[gpm_cell_array_update] gpm-cell-array.c:340 (16:39:20):         1 devices of
type primary
[gpm_cell_array_update] gpm-cell-array.c:386 (16:39:20):        
unit->percentage = 100
[gpm_profile_get_time] gpm-profile.c:250 (16:39:20):     percentage = 100,
correcting to 99
[gpm_profile_get_time] gpm-profile.c:250 (16:39:20):     percentage = 100,
correcting to 99
[gpm_check_device_key] gpm-cell-array.c:676 (16:39:20):  checking primary
against ups
[gpm_cell_array_add] gpm-cell-array.c:736 (16:39:20):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for ups
[gpm_cell_array_update] gpm-cell-array.c:273 (16:39:20):         no devices of
type 1
[gpm_check_device_key] gpm-cell-array.c:676 (16:39:20):  checking primary
against mouse
[gpm_cell_array_add] gpm-cell-array.c:736 (16:39:20):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for mouse
[gpm_cell_array_update] gpm-cell-array.c:273 (16:39:20):         no devices of
type 2
[gpm_check_device_key] gpm-cell-array.c:676 (16:39:20):  checking primary
against keyboard
[gpm_cell_array_add] gpm-cell-array.c:736 (16:39:20):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for keyboard
[gpm_cell_array_update] gpm-cell-array.c:273 (16:39:20):         no devices of
type 3
[gpm_check_device_key] gpm-cell-array.c:676 (16:39:20):  checking primary
against pda
[gpm_cell_array_add] gpm-cell-array.c:736 (16:39:20):    not adding
/org/freedesktop/Hal/devices/acpi_BAT0 for pda
[gpm_cell_array_update] gpm-cell-array.c:273 (16:39:20):         no devices of
type 4
[gpm_engine_get_icon] gpm-engine.c:366 (16:39:20):       Trying CRITICAL icon:
primary, ups, mouse, keyboard
*** WARNING ***
[gpm_warning_get_state_time] gpm-warning.c:85 (16:39:20):        time zero,
something's gone wrong
*** WARNING ***
[gpm_warning_get_state_percentage] gpm-warning.c:104 (16:39:20):        
percentage zero, something's gone wrong
[gpm_engine_get_icon] gpm-engine.c:390 (16:39:20):       Trying CHARGING icon:
primary, ups
[gpm_engine_get_icon] gpm-engine.c:407 (16:39:20):       Trying PRESENT icon:
primary, ups
[gpm_cell_unit_get_icon] gpm-cell-unit.c:199 (16:39:20):         got filename:
gpm-primary-charged
[gpm_engine_recalculate_state_icon] gpm-engine.c:530 (16:39:20):         **
EMIT: icon-changed: gpm-primary-charged
[gpm_tray_icon_set_icon] gpm-tray-icon.c:177 (16:39:20):         Setting icon to
gpm-primary-charged
[gpm_profile_get_accuracy] gpm-profile.c:647 (16:39:20):         corrected
percentage...
[gpm_cell_array_get_description] gpm-cell-array.c:905 (16:39:20):       
accuracy = 0
[gpm_profile_get_accuracy] gpm-profile.c:647 (16:39:20):         corrected
percentage...
[gpm_engine_get_summary] gpm-engine.c:328 (16:39:20):    tooltip: Computer is
running on AC power
Laptop battery fully charged (100%)
Battery charge profile is estimated
[gpm_engine_recalculate_state_summary] gpm-engine.c:570 (16:39:20):      **
EMIT: summary-changed(1): Computer is running on AC power
Laptop battery fully charged (100%)
Battery charge profile is estimated

[gpm_tray_icon_popup_menu_cb] gpm-tray-icon.c:440 (16:39:28):    icon right clicked
[gpm_tray_icon_popup_cleared_cd] gpm-tray-icon.c:365 (16:39:29):         clear
tray (icon = 0xa0b60f0)
[gpm_tray_icon_activate_cb] gpm-tray-icon.c:560 (16:39:30):      icon left clicked
[gpm_tray_icon_add_device] gpm-tray-icon.c:521 (16:39:30):       adding device '0'
[gpm_cell_unit_get_icon] gpm-cell-unit.c:199 (16:39:30):         got filename:
gpm-primary-charged
[gpm_tray_icon_popup_cleared_cd] gpm-tray-icon.c:365 (16:39:31):         clear
tray (icon = 0xa0b60f0)
[gpm_cell_unit_get_icon] gpm-cell-unit.c:199 (16:39:31):         got filename:
gpm-primary-charged
[gpm_notify_create] gpm-notify.c:127 (16:39:31):         libnotify: Power
Manager : <b>Product:</b> Battery Bay
<b>Status:</b> Charged
<b>Percentage charge:</b> 100%
<b>Vendor:</b> Panasonic
<b>Technology:</b> Lithium ion
<b>Serial number:</b> 1133
<b>Model:</b> DELL CC1546
<b>Capacity:</b> 89% (Fair)
<b>Current charge:</b> 46.8 Wh
<b>Last full charge:</b> 46.8 Wh
<b>Design charge:</b> 52.2 Wh
*** WARNING ***
[gpm_notify_show] gpm-notify.c:140 (16:39:31):   failed to send notification

------------
may be notify issue
Comment 7 Richard Hughes 2007-05-23 11:28:28 EDT
is notification-daemon running in gnome?
Comment 8 A S Alam 2007-05-28 03:19:58 EDT
how can I get that?

just a try
---
[root@alamPunjabi ~]# ps -auxxx|grep notif*|grep -v grep
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.7/FAQ
aalam    32228  0.0  0.3  24564  7944 ?        S    12:29   0:00
/usr/libexec/notification-area-applet
--oaf-activate-iid=OAFIID:GNOME_NotificationAreaApplet_Factory --oaf-ior-fd=21
aalam    32302  0.0  0.4  35860  8828 ?        S    12:29   0:00 knotify [kdeinit]  
---
Comment 9 Bug Zapper 2008-04-03 20:50:55 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Matthias Clasen 2008-04-03 22:45:47 EDT
Works fine in current rawhide. Closing this bug report.

Note You need to log in before you can comment on or make changes to this bug.