Bug 241000 - System-config-printer will not start
System-config-printer will not start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-23 12:19 EDT by Callum Benepe
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 13:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Callum Benepe 2007-05-23 12:19:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070417 Fedora/2.0.0.3-4.fc7 Firefox/2.0.0.3

Description of problem:
Hi All, sorry if this is a dupe. I looked for 10 minutes, but couldn't find.
When I try to configure a printer on F7 (installed & updated today 5/23/07) I get this error...thanks!
[root@localhost ~]# system-config-printer
Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 45, in <module>
    from foomatic import Foomatic
  File "/usr/share/system-config-printer/foomatic.py", line 24, in <module>
    from xml.utils import qp_xml
ImportError: No module named utils
[root@localhost ~]# 


Version-Release number of selected component (if applicable):
Fedora 7 - test 4

How reproducible:
Always


Steps to Reproduce:
1. [root@localhost ~]# system-config-printer
2.
3.

Actual Results:
Same as above

Expected Results:
Printer config gui

Additional info:
Comment 1 Tim Waugh 2007-05-23 13:00:32 EDT
What do these commands say?

rpm -q PyXML
rpm -q --requires system-config-printer-libs | grep PyXML
rpm -V system-config-printer{,-libs}
Comment 2 Callum Benepe 2007-05-23 13:31:53 EDT
[root@localhost ~]# rpm -q PyXML
package PyXML is not installed
[root@localhost ~]# 
[root@localhost ~]# rpm -q --requires system-config-printer-libs | grep PyXML
PyXML  
[root@localhost ~]# 
[root@localhost ~]# rpm -V system-config-printer{,-libs}
Unsatisfied dependencies for system-config-printer-libs-0.7.63.1-1.fc7.i386: PyXML
[root@localhost ~]# 
Comment 3 Tim Waugh 2007-05-24 04:32:13 EDT
So how did you install, and how did you update?
Comment 4 Callum Benepe 2007-05-24 11:17:11 EDT
Sorry for the slow reply. Traveled to NYC today, no access to FC7 until tomorrow.
I installed from a i386 DVD, Bittorent download from Fedora Wiki.
I have to admit that I use Yum from the command line because I like to monitor
the update progress.
Pup is good, but when dependency resolution etc.. takes awhile it just looks
frozen. Maybe we could geek Pup out a bit and add an open window option to show
the work in progress?
Kind of like the boot-up option.
Comment 5 Tim Waugh 2007-05-24 12:10:43 EDT
Never mind about pros/cons of different tools -- what happened here is that
system-config-printer-libs got installed without one of its dependencies, and so
whichever tool you *did* use did something wrong.  I think you're saying you
used anaconda to install (i.e. the normal way) and yum to upgrade in this
instance, so I'm changing the component to that (anaconda) and reassigning.
Comment 6 Jeremy Katz 2007-05-24 13:09:09 EDT
When did you do your install?  There was a point at which this was happening a
while back...
Comment 7 Callum Benepe 2007-05-24 13:51:39 EDT
I downloaded http://torrent.fedoraproject.org/torrents//f7-test4-i386.torrent
(DVD) Tuesday night 5/22 then installed & upgraded yesterday.
Comment 8 Jeremy Katz 2007-05-29 13:42:49 EDT
This should be fixed for F7 final
Comment 9 Callum Benepe 2007-05-29 14:25:13 EDT
I've been using Red Hat since 1998, really looking forward to FC7...thanks for
your help and best of luck!

Note You need to log in before you can comment on or make changes to this bug.