Bug 241006 - device-mapper mirror: bad call to dm_io in read_async_bio causes I/O failure
Summary: device-mapper mirror: bad call to dm_io in read_async_bio causes I/O failure
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jonathan Earl Brassow
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-23 16:27 UTC by Jonathan Earl Brassow
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:50:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Jonathan Earl Brassow 2007-05-23 16:27:05 UTC
read_async_bio calls dm_io as follows:
  (void) dm_io(&io_req, m->ms->nr_mirrors, &io, NULL);
since we are trying to do a read from only one device (not all mirror devices),
it should be
  (void) dm_io(&io_req, 1, &io, NULL);

Without this change, you will get:
BUG: warning at drivers/md/dm-io.c:460/async_io() (Not tainted)
 [<e085f9d3>] async_io+0x3e/0xa9 [dm_mod]
 [<e085fafa>] dm_io+0xbc/0xd1 [dm_mod]
 [<e080dce1>] read_callback+0x0/0x90 [dm_mirror]
 [<e085f4f9>] bvec_get_page+0x0/0x18 [dm_mod]
 [<e085f511>] bvec_next_page+0x0/0x5 [dm_mod]
 [<e080e485>] do_work+0x656/0xc7b [dm_mirror]
 [<e080dce1>] read_callback+0x0/0x90 [dm_mirror]
 [<c0433388>] run_workqueue+0x78/0xb5
 [<e080de2f>] do_work+0x0/0xc7b [dm_mirror]
 [<c0433c3c>] worker_thread+0xd9/0x10d
 [<c041ee15>] default_wake_function+0x0/0xc
 [<c0433b63>] worker_thread+0x0/0x10d
 [<c0436015>] kthread+0xc0/0xeb
 [<c0435f55>] kthread+0x0/0xeb
 [<c0405c3b>] kernel_thread_helper+0x7/0x10

Comment 1 RHEL Product and Program Management 2007-05-23 17:03:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Jonathan Earl Brassow 2007-05-23 19:19:02 UTC
assigned -> post

Comment 3 RHEL Product and Program Management 2007-05-23 19:21:34 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 4 Don Zickus 2007-06-12 18:46:35 UTC
in 2.6.18-24.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 7 errata-xmlrpc 2007-11-07 19:50:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.