Bug 241102 - fence_apc works not
Summary: fence_apc works not
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: fence   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
urgent
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
: 244610 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-24 06:24 UTC by Falk Hackenberger
Modified: 2009-04-16 20:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 14:30:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpump of communtication between host and fencing devic (536 bytes, application/octet-stream)
2007-05-24 06:28 UTC, Falk Hackenberger
no flags Details
strace output of fence apc (8.09 KB, application/octet-stream)
2007-05-24 06:29 UTC, Falk Hackenberger
no flags Details

Description Falk Hackenberger 2007-05-24 06:24:29 UTC
it try to use fence_apc with:

fence.strace fence_apc -a fence -l apc -p acp  -n 2

and i get this outpt:
---snip---
Traceback (most recent call last):
  File "/sbin/fence_apc", line 798, in ?
    main()
  File "/sbin/fence_apc", line 285, in main
    do_login(sock)
  File "/sbin/fence_apc", line 456, in do_login
    ndbuf = sock.read_eager() # Scoop up remainder
  File "/usr/lib/python2.3/telnetlib.py", line 377, in read_eager
    return self.read_very_lazy()
  File "/usr/lib/python2.3/telnetlib.py", line 400, in read_very_lazy
    raise EOFError, 'telnet connection closed'
EOFError: telnet connection closed
---snap---

the strace output of fence_apc is attached
also the tcpump of the communtication between host and fencing device

the fencing device is the apc ap7921

Comment 1 Falk Hackenberger 2007-05-24 06:28:18 UTC
Created attachment 155314 [details]
tcpump of communtication between host and fencing devic

Comment 2 Falk Hackenberger 2007-05-24 06:29:38 UTC
Created attachment 155315 [details]
strace output of fence apc

Comment 3 Bryn M. Reeves 2007-11-23 11:02:48 UTC
*** Bug 244610 has been marked as a duplicate of this bug. ***

Comment 4 Bryn M. Reeves 2007-11-23 11:18:52 UTC
This looks like a problem with the APC v.3 firmware, rather than anything
specific to the 7921 NPS. See bug 245675 for more infomation.

Comment 5 Jim Parsons 2008-02-27 14:30:01 UTC
The agent in current release was tested on an APC7921 a week ago, and worked
flawlessly. There were some issues with one of their 3.x firmware releases that
they have fixed in subsequent releases. I recommend upgrading to the latest apc
firmware if this condition persists.


Note You need to log in before you can comment on or make changes to this bug.