Bug 241103 - [FIX] /usr/sbin/bind-chroot-admin: line 224: [: : unary operator expected
[FIX] /usr/sbin/bind-chroot-admin: line 224: [: : unary operator expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
:
: 241271 241502 241608 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 03:15 EDT by Leszek Matok
Modified: 2013-04-30 19:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: 9.4.1-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 11:59:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leszek Matok 2007-05-24 03:15:05 EDT
When updating F6:
  Updating  : caching-nameserver           ####################### [11/39] 
/usr/sbin/bind-chroot-admin: line 224: [: : unary operator expected
  Updating  : bind-chroot                  ####################### [17/39] 
/usr/sbin/bind-chroot-admin: line 224: [: : unary operator expected

I think that's because I have SELinux disabled, otherwise this part of
master_zone_writes_enabled( ) wouldn't ever be interpreted.

I also think it's sufficient to get rid of "[yY1]*" (which is incorrect anyhow,
even if /usr/bin/[ would interpret regular expressions) and leave only:
if [ "$ENABLE_ZONE_WRITE" ]; then
This way, of course, even "no" is interpreted as "yes", but that's how
DISABLE_NAMED_DBUS is interpreted, as well. That's why I think it's enough :)
Comment 1 Adam Tkac 2007-05-24 09:46:04 EDT
We could try use non-rough solution. Something like
if `echo "$ENABLE_ZONE_WRITE" | grep -q '[yY1].*'`; then ... could be best.

-A-
Comment 2 Adam Tkac 2007-05-24 10:45:09 EDT
Could be fixed in bind-9.3.4-6.fc6.

Regards, Adam
Comment 3 Adam Tkac 2007-05-24 14:49:18 EDT
*** Bug 241271 has been marked as a duplicate of this bug. ***
Comment 4 Adam Tkac 2007-05-28 08:37:58 EDT
*** Bug 241502 has been marked as a duplicate of this bug. ***
Comment 5 Adam Tkac 2007-05-29 07:33:24 EDT
*** Bug 241608 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2007-06-08 11:59:04 EDT
bind-9.4.1-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.