Bug 241147 - Grub ignores timeout if hibernated
Summary: Grub ignores timeout if hibernated
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-24 09:58 UTC by Christian Jung
Modified: 2012-08-01 18:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 18:14:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Jung 2007-05-24 09:58:37 UTC
Description of problem:
If you hibernate a machine and power it on, grub boots immediately the last
entry. Grub ignores a specified timeout in /boot/grub/menu.lst

If you shutdown the machine and power it on, timeout is not ignored.

This is a problem on multi-boot system, where you don't always want to boot into
RHEL.

Version-Release number of selected component (if applicable):
grub-0.97-13


How reproducible:
always

Steps to Reproduce:
1. Log into GNOME
2. select System, Shutdown, Hibernate
3. Power on system
  
Actual results:
GRUB ignores timeout specified in /boot/grub/menu.lst and boots directly into RHEL.

Expected results:
GRUB menu should wait for specified timeout, to be able to boot another OS (on
Multi Boot systems)


Additional info:
none

Comment 1 Luis 2007-12-30 16:15:28 UTC
Exactly the same problem here with Fedora 8, fresh installation

Comment 2 Stephen Warren 2008-09-14 03:42:16 UTC
Same thing still present in Fedora 9, and very annoying.

I ended up installing Fedora's bootloader in the /boot partition instead of MBR, and installing Puppy Linux, with its grub in the MBR, so I had a separate grub instance to allow selecting Windows

Comment 3 Stephen Warren 2008-09-16 03:03:32 UTC
What's even more annoying about this is that if you attempt to hibernate the machine, and the hibernate fails (e.g. bug 462204) then grub is still set to ignore the timeout. This means that when you restart, or shutdown/poweron, after the failed hibernate, you'll be forced back into the same kernel you were running during the failed hibernate attempt, and hence can't e.g. switch to a newly installed kernel, or manually select a kernel for testing.

Comment 4 Stephen Warren 2008-11-26 00:18:08 UTC
I eventually ended up installing a tiny 100M extra Linux partition with some tiny Linux distro, made that distro install grub to the MBR, then made Fedora install its grub to the partition instead of the MBR. Now, the MBR's grub is never screwed with when Fedora hibernates, and I can choose which OS install to boot always. The lack-of-timeout only affects the Fedora installation, after I've chosen that.

Comment 5 Vladimir Serbinenko 2012-08-01 18:14:16 UTC
I believe this is a feature, not a bug. After hibernation you have to boot exactly the same kernel as you booted before or otherwise you get into troubles unless you know what you do but if you do, you know how to disable this behaviour as well.


Note You need to log in before you can comment on or make changes to this bug.