Bug 241157 - please update to 2.8.4
Summary: please update to 2.8.4
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Miller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 241450 244592
TreeView+ depends on / blocked
 
Reported: 2007-05-24 10:20 UTC by Dan Horák
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version: 2.8.4-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 03:43:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Horák 2007-05-24 10:20:49 UTC
Please, can you update wxGTK to version 2.8.4? It fixes a bug that affects my
package codeblocks.

Comment 1 Matthew Miller 2007-05-24 11:08:20 UTC
I'm hesitant to do it for Fedora 7 at this point, because in my experience every
time I update wxGTK and wxPython (which go hand-in-hand) something new breaks.
Can you give me some more details (and put the blocked bug as a blocker of this
one)? Thanks.

Comment 2 Dan Horák 2007-06-06 15:01:09 UTC
Upstream (codeblocks) discussion is at
http://forums.codeblocks.org/index.php/topic,5805.0.html

Now with the bohdi tool we have updates-testing also for former Extras packages.
So it makes possible to prepare an updated package and put it into "testing"
even for a long time. I can then advise the reporters of the codeblocks' bug to
install 2.8.4 from "testing".

Comment 3 Matthew Miller 2007-06-06 21:02:14 UTC
Thanks for your patience on this. I'll build for testing as soon as I get a chance.

Comment 4 Matthew Miller 2007-06-17 23:20:34 UTC
Status update: busy at work + new build system = slower than I'd like to be on
this. Sorry. Will dedicate some time to it this week.

Comment 5 Peter Gordon 2007-07-07 18:59:44 UTC
Any updates on this, Matthew? I'd like to see if 2.8.4 fixes a crasher issue
I've been having before posting a full BZ for it. 

Thanks.

Comment 6 Dan Horák 2007-07-08 08:24:08 UTC
Can we help you somehow? For example you could only commit into CVS what you
have prepared now, and we can try building and polishing it.

Comment 7 Matthew Miller 2007-07-11 19:06:34 UTC
Building into rawhide now. Sorry for the long delay. Will also build for
updates-testing tomorrow.

Comment 8 Dan Horák 2007-07-13 15:37:18 UTC
My bug #241450 is really fixed with 2.8.4 at least in rawhide, so really thanks
for the update. When will you push the Fedora 7 update? It is built in Koji, but
I cannot find it in Bodhi (it must be done manually by the maintainer).

Comment 9 Matthew Miller 2007-07-13 16:35:38 UTC
Needs to go out with wxPython, which won't build because it can't find the new
wxGTK 2.8.4. Not sure how to make it available without pushing the update. Oh,
the joys of a new build system. 

Comment 10 Matthew Miller 2007-07-16 16:15:17 UTC
This is now in updates-testing (and rawhide). Could people please test to verify
that the known problems are fixed and that new problems haven't appeared? Thanks!

Comment 11 Fedora Update System 2007-07-16 16:53:06 UTC
wxGTK-2.8.4-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Kevin Kofler 2007-08-01 23:41:21 UTC
I have verified that 2.8.4 fixes the Code::Blocks crash. Please push it to 
stable ASAP.

Comment 13 Fedora Update System 2007-08-02 03:43:49 UTC
wxGTK-2.8.4-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.