Bug 24120 - installation fails
Summary: installation fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-16 16:39 UTC by Mike Schiraldi
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-26 23:44:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Schiraldi 2001-01-16 16:39:55 UTC
When attempting to "upgrade" from a screwed-up version of 7.0 to a new
installation of 7.0, anaconda fails:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    return _gtk.gtk_quit_add(mainlevel, callback, args)
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 412, in
nextClic
ked
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/examine_gui.py", line
19, i
n getNext
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 952, in
upgrade
FindPackages
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 310, in
setClo
ck
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 75, in
execWit
hRedirect
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
argv: ('bash', '-c', '\012if [ -f /etc/sysconfig/clock ]; then\012   .
/etc/sysc
onfig/clock\012   \012   # convert old style clock config to new values\012 if
 [ "${CLOCKMODE}" = "GMT" ]; then\012      UTC=true\012   elif [
"${CLOCKMODE}"
= "ARC" ]; then\012      ARC=true\012
fi\012fi\012\012CLOCKFLAGS="--hctosys"\0
12\012case "$UTC" in\012   yes|true)\012    CLOCKFLAGS="$CLOCKFLAGS
-u";\012
 ;;\012esac\012\012case "$ARC" in\012     yes|true)\012
CLOCKFLAGS="$CLOC
KFLAGS -A";\012     ;;\012esac\012case "$SRM" in\012     yes|true)\012
   CL
OCKFLAGS="$CLOCKFLAGS -S";\012     ;;\012esac\012/sbin/hwclock
$CLOCKFLAGS\012')
childpid: 0
root: /mnt/sysimage
stdin: 11
newPgrp: 0
stdout: 12
stderr: 12
command: /bin/sh
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo

ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2001-01-17 18:01:09 UTC
How was it screwed up?

Comment 2 Mike Schiraldi 2001-01-17 19:23:31 UTC
A little "rpm --force --nodeps", a little "mv /usr/lib/lib<whatever> <whatever>"
.. the symptom was that all of a sudden, nothing worked and i was like, "Gee, i
think i screwed up libc. I should probably move that file back where it was.
Hmm, mv doesn't work. Hmm, ls doesn't work. Hmm. Well, i don't think a reboot
will help, but what the hey. Hmm, init not found. That's not good."

So i decided to reinstall and have it hopefully overwrite all the bad libs. But
it would die at that point. I would have done some debugging, but when i clicked
"Debug", the GUI would hang (i'd switch to another terminal and come back to
Alt-F7, and there would be a bunch of gray rectangles, signifying widgets that
refused to redraw themselves. I'm sure you know what i'm talking about, like
when you run an application without the & and then ctrl-z to stop it and then
move the window around)

I've got my system up and running again, though, so i can't do any more
experimenting.

Comment 3 Michael Fulbright 2001-01-26 23:43:59 UTC
Assigning to a developer.

Comment 4 Brent Fox 2001-02-05 22:42:15 UTC
Resolving as not a bug.


Note You need to log in before you can comment on or make changes to this bug.