Bug 241245 - tomcat5-5.5.23-9jpp.2.fc7 broken - will this go into f7?
tomcat5-5.5.23-9jpp.2.fc7 broken - will this go into f7?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vivek Lakshmanan
:
: 242340 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 11:56 EDT by Oliver Falk
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.3-9jpp.2.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-09 15:19:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-05-24 11:56:30 EDT
Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:       
May 24, 2007 5:53:44 PM org.apache.catalina.core.AprLifecycleListener lifecycleE
vent
INFO: The Apache Tomcat Native library which allows optimal performance in produ
ction environments was not found on the java.library.path: /usr/lib/jvm/java-1.5
.0-sun-1.5.0.05/jre/lib/i386/client:/usr/lib/jvm/java-1.5.0-sun-1.5.0.05/jre/lib
/i386:/usr/lib/jvm/java-1.5.0-sun-1.5.0.05/jre/../lib/i386
May 24, 2007 5:53:44 PM org.apache.commons.modeler.Registry registerComponent
SEVERE: Error registering Catalina:type=StringCache
sun.misc.InvalidJarIndexException: Invalid index
        at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:769)
        at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:682)
        at sun.misc.URLClassPath$JarLoader.findResource(URLClassPath.java:663)
        at sun.misc.URLClassPath.findResource(URLClassPath.java:142)
        at java.net.URLClassLoader$2.run(URLClassLoader.java:362)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findResource(URLClassLoader.java:359)
        at java.lang.ClassLoader.getResource(ClassLoader.java:977)
        at java.lang.ClassLoader.getResource(ClassLoader.java:972)
        at org.apache.commons.modeler.Registry.loadDescriptors(Registry.java:867
)
        at org.apache.commons.modeler.Registry.findDescriptor(Registry.java:960)
        at org.apache.commons.modeler.Registry.findManagedBean(Registry.java:665
)
        at org.apache.commons.modeler.Registry.findManagedBean(Registry.java:101
4)
        at org.apache.commons.modeler.Registry.registerComponent(Registry.java:8
31)
        at org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
a:775)
        at org.apache.catalina.startup.Catalina.load(Catalina.java:504)
        at org.apache.catalina.startup.Catalina.load(Catalina.java:524)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:267)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:432)
May 24, 2007 5:53:44 PM org.apache.catalina.core.StandardServer initialize
SEVERE: Error registering 


It's the same with gcj, not only Sun's JDK. Please make sure we don't have this
in f7!!!
Comment 1 Oliver Falk 2007-05-24 11:59:13 EDT
If it will go into F7, please add it to #150226
Comment 2 Oliver Falk 2007-05-29 03:31:55 EDT
ping
Comment 3 Vivek Lakshmanan 2007-05-29 12:46:20 EDT
(In reply to comment #0)
> 
> It's the same with gcj, not only Sun's JDK. Please make sure we don't have this
> in f7!!!

I tested this before the update to F7 was made on i386 rawhide and now on an
x86_64 rawhide box. This is what I get with service tomcat5 start:

Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:
Created MBeanServer with ID: -8f0im4:f2ag64b8.0:to-gcj-1.toronto.redhat.com:1
29-May-07 10:10:49 AM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in
production environments was not found on the java.library.path: /usr/lib64/gcj-4.1.2
29-May-07 10:10:50 AM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
29-May-07 10:10:50 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 2263 ms
29-May-07 10:10:50 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
29-May-07 10:10:50 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.23
29-May-07 10:10:50 AM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
29-May-07 10:10:50 AM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
29-May-07 10:10:50 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
29-May-07 10:10:50 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/152  config=null
29-May-07 10:10:51 AM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
29-May-07 10:10:51 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 1029 ms

The issue is only on proprietary JVMs (not supported on Fedora) and certainly
not a blocker for a Fedora release - please refer to
http://fedoraproject.org/wiki/QA/ReleaseCriteria

This is a manifestation of bug 234286 where the INDEX.LIST was being improperly
modified by a post build hook. There may be a jar picked up during the tomcat5
init which slipped through before the fix for bug 234286 made it through, will
investigate now.
Comment 4 Vivek Lakshmanan 2007-06-04 11:47:53 EDT
*** Bug 242340 has been marked as a duplicate of this bug. ***
Comment 5 Rubens Gomes 2007-06-06 12:49:43 EDT
FYI. I am still having problems.  Here is further info:

[root@localhost tomcat5]# yum list installed 'tomcat*'
Loading "installonlyn" plugin
Installed Packages
tomcat5.i386                             5.5.23-0jpp.1.0.3.el5  installed
tomcat5-admin-webapps.i386               5.5.23-0jpp.1.0.3.el5  installed
tomcat5-common-lib.i386                  5.5.23-0jpp.1.0.3.el5  installed
tomcat5-jasper.i386                      5.5.23-0jpp.1.0.3.el5  installed
tomcat5-jsp-2.0-api.i386                 5.5.23-0jpp.1.0.3.el5  installed
tomcat5-server-lib.i386                  5.5.23-0jpp.1.0.3.el5  installed
tomcat5-servlet-2.4-api.i386             5.5.23-0jpp.1.0.3.el5  installed
tomcat5-webapps.i386                     5.5.23-0jpp.1.0.3.el5  installed


[root@localhost init.d]# /etc/init.d/tomcat5 version Server version: Apache
Tomcat/5.5.20
Server built:   May 14 2007 05:33:51
Server number:  5.5.20.0
OS Name:        Linux
OS Version:     2.6.18-8.1.4.el5
Architecture:   i386
JVM Version:    1.5.0_12-b04
JVM Vendor:     Sun Microsystems Inc.
[root@localhost init.d]#


portion of catalina.out:
Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:       
Jun 6, 2007 9:23:28 AM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in
production environments was not found on the java.library.path:
/usr/lib/jvm/java-1.5.0-sun-1.5.0.12/jre/lib/i386/client:/usr/lib/jvm/java-1.5.0-sun-1.5.0.12/jre/lib/i386:/usr/lib/jvm/java-1.5.0-sun-1.5.0.12/jre/../lib/i386
Jun 6, 2007 9:23:28 AM org.apache.commons.modeler.Registry registerComponent
SEVERE: Error registering Catalina:type=StringCache
sun.misc.InvalidJarIndexException: Invalid index
	at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:769)
	at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:682)
	at sun.misc.URLClassPath$JarLoader.findResource(URLClassPath.java:663)
	at sun.misc.URLClassPath.findResource(URLClassPath.java:142)
	at java.net.URLClassLoader$2.run(URLClassLoader.java:362)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findResource(URLClassLoader.java:359)
	at java.lang.ClassLoader.getResource(ClassLoader.java:977)
	at org.apache.commons.modeler.Registry.loadDescriptors(Registry.java:895)
	at org.apache.commons.modeler.Registry.findDescriptor(Registry.java:992)
	at org.apache.commons.modeler.Registry.findManagedBean(Registry.java:696)
	at org.apache.commons.modeler.Registry.findManagedBean(Registry.java:1047)
	at org.apache.commons.modeler.Registry.registerComponent(Registry.java:859)
	at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:775)
	at org.apache.catalina.startup.Catalina.load(Catalina.java:504)
	at org.apache.catalina.startup.Catalina.load(Catalina.java:524)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:267)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:432)
Jun 6, 2007 9:23:28 AM org.apache.catalina.core.StandardServer initialize
SEVERE: Error registering 
Comment 6 Vivek Lakshmanan 2007-06-07 01:40:01 EDT
Looks like the issue is in the jakarta-commons-{collections,pool}-tomcat5's
INDEX.LIST. Koji seems down ATM so will push builds for -collections tomorrow
and ask dbhole to rebuild -pool as well (added to CC).
Comment 7 Oliver Falk 2007-06-07 14:27:13 EDT
As far as I can remember, I also tried it with gcj and it was the same problem.
Maybe some links that still pointed to sun's jdk... I don't know. However,
should work with proprietary JDKs as well. /me thinks.
Comment 8 Vivek Lakshmanan 2007-06-07 19:10:55 EDT
I submitted update requests on bodhi for the two. In the meantime, could you try
installing packages for your arch from the locations below and report if the
issue is fixed?

http://koji.fedoraproject.org/packages/jakarta-commons-collections/3.1/9jpp.2.fc7.1/
http://koji.fedoraproject.org/packages/jakarta-commons-pool/1.3/9jpp.2.fc7.1/
Comment 9 Oliver Falk 2007-06-08 03:43:53 EDT
Jup. That's working fine!
Comment 10 Fedora Update System 2007-06-08 11:54:46 EDT
jakarta-commons-collections-3.1-9jpp.2.fc7.1 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2007-06-08 11:54:54 EDT
jakarta-commons-pool-1.3-9jpp.2.fc7.1 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2007-06-09 15:19:38 EDT
jakarta-commons-pool-1.3-9jpp.2.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2007-06-09 15:19:47 EDT
jakarta-commons-collections-3.1-9jpp.2.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.