Bug 241255 - keyboard navigation improvement on Firewall screen [NEEDINFO]
Summary: keyboard navigation improvement on Firewall screen
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Benjamin Otte
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-24 16:46 UTC by Geoff Gustafson
Modified: 2014-06-02 13:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 13:04:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (grgustaf)


Attachments (Terms of Use)

Description Geoff Gustafson 2007-05-24 16:46:48 UTC
Description of problem:
On the firstboot Firewall screen, not only are the checkboxes in the listbox
navigable, but also the text items next to them. But you can't press spacebar to
select the checkbox when you have those selected. I accidentally got onto those
and was confused for a bit on why I couldn't select the checkbox. There's no
reason for those to be navigable so either removing that or making spacebar
active the checkbox would fix the problem. This might occur on other screens as
well.

Obviously not a big deal, but it did make me think kbd navigation was broken for
30s or so. :)

Version-Release number of selected component (if applicable):
RHEL5 GA, found during i386 install

Comment 1 Thomas Woerner 2007-06-12 13:50:56 UTC
I am sorry, but I can not reproduce the problem. The text next to the check
boxes is not selectable at all. Can you please try to verify this?

Comment 2 Geoff Gustafson 2007-10-29 20:24:28 UTC
Still reproducible in 5.1 RC5.

Tab to the listbox containing:
[] FTP
[] Mail

etc. First, one of the checkboxes will be highlighted by a dotted line. If you
press the right arrow (e.g. accidentally, like I did originally), the text "FTP"
becomes selected. Now you can go up and down with the arrows, but pressing
'Space' does not select an item. The selection bar changes but if you don't
notice that the checkbox itself is not selected it can be confusing why it's not
working.

If you go back to the previous wizard page, and return, you're still selected on
the wrong part of the item so a user could remain confused if they don't have a
mouse available.

Maybe other users would figure out to left-arrow back to the checkbox, just like
I did.


Comment 3 Thomas Woerner 2007-10-30 11:36:55 UTC
Is this the text or graphical version of firstboot?


Comment 4 Geoff Gustafson 2007-10-30 17:35:19 UTC
Graphical - I haven't used text-mode for so long I didn't think to distinguish.

Comment 5 Thomas Woerner 2007-10-31 14:15:54 UTC
This is a gtk TreeView problem. I tried to fix it in the application, but it is
not possible.

Assigning to gtk.

Comment 6 RHEL Product and Program Management 2009-03-26 17:06:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 10 RHEL Product and Program Management 2014-03-07 13:36:19 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 11 RHEL Product and Program Management 2014-06-02 13:04:41 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.