Bug 24129 - Anaconda fails during Kickstart install (line 438)
Summary: Anaconda fails during Kickstart install (line 438)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-16 20:20 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 17:25:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file (201.00 KB, text/plain)
2001-01-16 20:22 UTC, Need Real Name
no flags Details
Kickstart file (1.04 KB, text/plain)
2001-01-17 21:25 UTC, Need Real Name
no flags Details
Different kickstart file (5.42 KB, text/plain)
2001-01-18 19:39 UTC, Need Real Name
no flags Details
dump file (1.04 KB, text/plain)
2001-04-11 00:53 UTC, Chris Noe
no flags Details
kickstart file causing anaconda exception (2.29 KB, text/plain)
2001-04-11 00:54 UTC, Chris Noe
no flags Details

Description Need Real Name 2001-01-16 20:20:23 UTC
When doing a Kickstart install under 7.0 after loading some of the drivers
installation fails. I have saved the copy of the dump file (let me know who
should I e-mail it to). First few lines of the dump say something like this

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1413, in
doInstall    self.getCompsList()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 540, in
getCompsList
    self.updateInstClassComps()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 558, in
updateInstClassComps
    self.comps[n].select()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 248, in
__getitem__
    return self.compsDict[key]
KeyError: libc5_compat

Comment 1 Need Real Name 2001-01-16 20:22:24 UTC
Created attachment 7710 [details]
Anaconda dump file

Comment 2 Michael Fulbright 2001-01-17 18:52:20 UTC
Could you attach the kickstart file please?

Comment 3 Need Real Name 2001-01-17 20:27:10 UTC
When I try to install from a disk that I received via FTP, I get the exact same 
error message.

Comment 4 Need Real Name 2001-01-17 21:25:54 UTC
Created attachment 7749 [details]
Kickstart file

Comment 5 Need Real Name 2001-01-18 16:39:06 UTC
I got an e-mail this morning from Seth Vidal (skvidal at phy.duke.edu) who has a
CGI that builds the kickstart file I was using. This is his answer to my
question:

========================================================================== 
remove this line from your ks.cfg
@ libc5_compat

that is what doing it.

the libc5_compat group is a special one added by the dulug branch of the
redhat tree (I maintain that branch for duke university)

so its not a redhat bug at all.

You're just pointing to a "proprietary" tree.

I added the libc5_compat tree so it would push in the libc5 libs and ld.so
from 6.2 - so old binary-only apps would work with rh 7.

==========================================================================

I removed the entry as suggested and Kickstart installation seems to be working
now.

Comment 6 Need Real Name 2001-01-18 19:39:56 UTC
Created attachment 7808 [details]
Different kickstart file

Comment 7 Need Real Name 2001-01-18 19:45:55 UTC
After being successful with my kickstart file I wanted to make a more customized
installation of RedHat ie. instead of "Development" bundle I wanted only
particular packages. I had a reference RH7 box. Using

/usr/sbin/mkkickstart

I created a KS file (it is attached as ks.cfg.my.2 to this bug) but when it
comes to package selection it fails. It now crossed my mind that I installed new
packages ie. KDE 2, acrobat which are not in default RedHat installation.

Comment 8 Michael Fulbright 2001-01-19 17:25:16 UTC
Ok thanks for following up your own bug with the additional information.

Comment 9 Chris Noe 2001-04-11 00:50:35 UTC
Got same exception, but my ks.cfg does not contain libc5-compat.

Comment 10 Chris Noe 2001-04-11 00:53:24 UTC
Created attachment 15104 [details]
dump file

Comment 11 Chris Noe 2001-04-11 00:54:43 UTC
Created attachment 15105 [details]
kickstart file causing anaconda exception

Comment 12 Brock Organ 2001-04-11 18:23:45 UTC
Hi Chris,

Please remove the line "ld.so" from your package list. Kickstart is trying to 
find a package with that name and failing ...



Note You need to log in before you can comment on or make changes to this bug.