Bug 241394 - vavoom segfaults on exit
vavoom segfaults on exit
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vavoom (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 13:39 EDT by Wart
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-26 03:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wart 2007-05-25 13:39:30 EDT
Description of problem:
vavoom segfaults on exit

Version-Release number of selected component (if applicable):
1.23-2.fc6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start vavoom in a debugger:
gdb vavoom
run -iwaddir ~/.vavoom/heretic-shareware -heretic
2. Choose 'quit' from the main menu
  
Actual results:
gdb catches a seg fault with the following backtrace:


(gdb) bt
#0  ~VClass (this=0x899c00) at array.h:54
#1  0x000000397e832ed5 in exit () from /lib64/libc.so.6
#2  0x0000000000547382 in Sys_Quit (
    EndText=0x7fff8377e390 " \017
\017�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@�@
\017 \017 \017 \017 O O O O O O O O O O O O O O O O O O"...) at sys_sdl.cpp:396
                                                 
#3  0x000000000044f976 in Host_Quit () at host.cpp:630
#4  0x000000000044fc1a in Host_Frame () at host.cpp:371
#5  0x0000000000546e65 in main (argc=<value optimized out>, 
    argv=<value optimized out>) at sys_sdl.cpp:675
#6  0x000000397e81da44 in __libc_start_main () from /lib64/libc.so.6
#7  0x0000000000407269 in _start ()

Expected results:

No seg fault

Additional info:

It seems that vavoom also does not save the user preference file, which results
in the 'screen resolution' option getting reset every time the game is started.
 My guess is that the routine to save options to disk would normally happen at
some point after the seg fault is received.

I'm not sure if this is related or even supported, but vavoom also does not seem
to be able to change the resolution while the game is running.
Comment 1 Hans de Goede 2007-05-25 14:46:38 EDT
(In reply to comment #0)
> Description of problem:
> vavoom segfaults on exit
> 
> Version-Release number of selected component (if applicable):
> 1.23-2.fc6.x86_64
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. Start vavoom in a debugger:
> gdb vavoom
> run -iwaddir ~/.vavoom/heretic-shareware -heretic
> 2. Choose 'quit' from the main menu
>   
> Actual results:
> gdb catches a seg fault with the following backtrace:
> 

Followed you're instructions to the letter (F7-test4 / devel system, x86_64),
and it works fine for me.

> 
> I'm not sure if this is related or even supported, but vavoom also does not seem
> to be able to change the resolution while the game is running.

That works fine for me to, go to options->screen resolution, change, then select
set resolution option and press enter and voila it is done.
Comment 2 Wart 2007-05-25 17:31:36 EDT
I erased my $HOME/.vavoom directory and tried again.  This time it worked.  I
probably had some leftover cruft in that directory from older vavoom installations.

I also figured out that the screen resolution not changing was due to
incompatible resolution+bit depth settings.  For whatever reason, it refuses to
run at 24bpp @ 1024x768, but 32bpp works fine.

Anyway, this is no longer a bug.  Feel free to close it as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.