Bug 241406 - Misleading "deprecated" message for Authclass directive
Summary: Misleading "deprecated" message for Authclass directive
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
low
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-25 20:05 UTC by Valdis Kletnieks
Modified: 2009-01-20 21:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 21:58:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:0201 normal SHIPPED_LIVE cups enhancement update 2009-01-20 16:06:07 UTC
CUPS Bugs and Features 2400 None None None Never

Description Valdis Kletnieks 2007-05-25 20:05:08 UTC
Description of problem:
Seen in the error_log:
"AuthClass System" is deprecated; consider using "Require @SYSTEM" on line 843.

However, actually putting in 'Require @SYSTEM' instead causes a failure at
startup because that's the wrong syntax.  The message should probably recommend
'Require User @SYSTEM' instead.

Version-Release number of selected component (if applicable):
cups-1.2.4-11.5.1.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 RHEL Product and Program Management 2008-06-02 20:36:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Phil Knirsch 2008-06-13 13:33:36 UTC
Granting Devel ACK.

Read ya, Phil


Comment 9 errata-xmlrpc 2009-01-20 21:58:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html


Note You need to log in before you can comment on or make changes to this bug.