Bug 241443 - crashes on startup
crashes on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: magic (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-25 20:36 EDT by Bill Nottingham
Modified: 2014-03-16 23:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.4.35-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 16:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-05-25 20:36:02 EDT
Description of problem:

#0  0x0000003c51e5228e in glLineWidth () from /usr/lib64/libGL.so.1
#1  0x00002aaaaf574aa4 in GrTOGLInit () at grTOGL1.c:305
#2  0x00002aaaaf574e86 in oglSetDisplay (dispType=0x0,
outFileName=0x2aaaab6ba4f0 "\001", 
    mouseFileName=<value optimized out>) at grTOGL1.c:948
#3  0x00002aaaaf567af4 in GrSetDisplay (type=0xae0740 "OGL",
outName=0x2aaaaf61843b "/dev/null", 
    mouseName=0x2aaaaf61843b "/dev/null") at grMain.c:287
#4  0x00002aaaaf5b0e80 in mainInitAfterArgs () at main.c:507
#5  0x00002aaaaf60af08 in _magic_initialize (clientData=<value optimized out>,
interp=0x7a13f0, argc=4, 
    argv=0x7fffd9f1a070) at tclmagic.c:500
#6  0x0000003c4e42c539 in TclInvokeStringCommand (clientData=0xa2c5e0,
interp=0x7a13f0, objc=4, objv=0x7fffd9f1a320)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:1775
#7  0x0000003c4e42dc23 in TclEvalObjvInternal (interp=0x7a13f0, objc=4,
objv=0x7fffd9f1a320, 
    command=0x3c4e49d2ee "", length=0, flags=<value optimized out>)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3087
#8  0x0000003c4e42e9b3 in Tcl_EvalObjv (interp=0x7a13f0, objc=4,
objv=0x7fffd9f1a320, flags=262144)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3203
#9  0x0000003c4e42ecd5 in Tcl_EvalObjEx (interp=0x0, objPtr=0x614b40, flags=262144)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:4030
#10 0x0000003c4e434ef5 in Tcl_EvalObjCmd (dummy=<value optimized out>,
interp=0x7a13f0, objc=<value optimized out>, 
    objv=0x602350) at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclCmdAH.c:602
#11 0x0000003c4e42dc23 in TclEvalObjvInternal (interp=0x7a13f0, objc=2,
objv=0x7fffd9f1a730, 
    command=0xb5d58a "eval $argafter \t\t\t;# magic::initialize ${argv}\n\n#",
'-' <repeats 70 times>, "\n# Check for presence of padlist manager script and
include it\n\nif {[file exists "..., length=19, flags=<value optimized out>)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3087
#12 0x0000003c4e42e11b in Tcl_EvalEx (interp=0x7a13f0, 
    script=0xb5bf40 "# Wishrc startup for ToolScript (magic)\n#\n# For
installation:  Put this file and also magicwrap.so into\n# directory
/usr/lib64/magic/tcl, and set the \"load\" line below\n# to point to the
location of ma"..., 
    numBytes=<value optimized out>, flags=-638474432) at
/usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3689
#13 0x0000003c4e4710f7 in Tcl_FSEvalFile (interp=0x7a13f0, pathPtr=0x941640)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclIOUtil.c:1764
#14 0x0000003c4e42dc23 in TclEvalObjvInternal (interp=0x7a13f0, objc=2,
objv=0x975448, command=0x0, length=0, 
    flags=<value optimized out>) at
/usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3087
#15 0x0000003c4e456ba1 in TclExecuteByteCode (interp=0x7a13f0, codePtr=0xa5d620)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclExecute.c:1419
#16 0x0000003c4e459ffe in TclCompEvalObj (interp=0x7a13f0, objPtr=0x9557a0)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclExecute.c:981
#17 0x0000003c4e42eb20 in Tcl_EvalObjEx (interp=0x0, objPtr=0x2aaaab6ba4f0, flags=0)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:4051
#18 0x0000003c4e461100 in SlaveEval (interp=0x60e900, slaveInterp=0x7a13f0,
objc=1, objv=0x61bc10)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclInterp.c:2094
#19 0x0000003c4e46234f in Tcl_InterpObjCmd (clientData=<value optimized out>,
interp=0x60e900, objc=4, objv=0x61bbf8)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclInterp.c:529
#20 0x0000003c4e42dc23 in TclEvalObjvInternal (interp=0x60e900, objc=4,
objv=0x61bbf8, command=0x0, length=0, 
    flags=<value optimized out>) at
/usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3087
#21 0x0000003c4e456ba1 in TclExecuteByteCode (interp=0x60e900, codePtr=0x90af00)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclExecute.c:1419
#22 0x0000003c4e459ffe in TclCompEvalObj (interp=0x60e900, objPtr=0x6192b0)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclExecute.c:981
#23 0x0000003c4e481dfc in TclObjInterpProc (clientData=0x6d5890,
interp=0x60e900, objc=1, objv=0x61bbe8)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclProc.c:1100
#24 0x0000003c4e42dc23 in TclEvalObjvInternal (interp=0x60e900, objc=1,
objv=0x61bbe8, command=0x0, length=0, 
    flags=<value optimized out>) at
/usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3087
#25 0x0000003c4e456ba1 in TclExecuteByteCode (interp=0x60e900, codePtr=0x8710f0)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclExecute.c:1419
#26 0x0000003c4e459ffe in TclCompEvalObj (interp=0x60e900, objPtr=0x87b8e0)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclExecute.c:981
#27 0x0000003c4e42eb20 in Tcl_EvalObjEx (interp=0x0, objPtr=0x2aaaab6ba4f0, flags=0)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:4051
#28 0x0000003c4e439df1 in Tcl_IfObjCmd (dummy=<value optimized out>,
interp=0x60e900, objc=3, objv=0x7fffd9f1bf70)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclCmdIL.c:277
#29 0x0000003c4e42dc23 in TclEvalObjvInternal (interp=0x60e900, objc=3,
objv=0x7fffd9f1bf70, 
    command=0x83c043 "if {![info exists ::tkcon::PRIV(root)] || \\\n\t![winfo
exists $::tkcon::PRIV(root)]} {\n    ::tkcon::Init\n}\n", length=105,
flags=<value optimized out>)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3087
#30 0x0000003c4e42e11b in Tcl_EvalEx (interp=0x60e900, 
    script=0x814500 "#!/bin/sh\n# \\\nexec ${MAGIC_WISH:=wish} \"$0\"
${1+\"$@\"}\n\n#\n## tkcon.tcl\n## Enhanced Tk Console, part of the VerTcl
system\n##\n## Originally based off Brent Welch's Tcl Shell Widget\n## (from
\"Practical Pr"..., numBytes=<value optimized out>, flags=-638468216)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclBasic.c:3689
#31 0x0000003c4e4710f7 in Tcl_FSEvalFile (interp=0x60e900, pathPtr=0x614e40)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclIOUtil.c:1764
#32 0x0000003c4e4711df in Tcl_EvalFile (interp=0x60e900, fileName=<value
optimized out>)
    at /usr/src/debug/tcl-8.4.13/tcl8.4.13/generic/tclIOUtil.c:291
#33 0x0000003c4e8477c6 in Tk_MainEx (argc=-638467504, argv=<value optimized out>, 
    appInitProc=0x400910 <Tcl_AppInit>, interp=0x60e900) at
/usr/src/debug/tk8.4.13/generic/tkMain.c:248
#34 0x000000000040099e in main (argc=6, argv=0x7fffd9f1c548) at
/usr/src/debug/tk8.4.13/unix/tkAppInit.c:68

Version-Release number of selected component (if applicable):

magic-7.4.35-1.fc7
Comment 1 Chitlesh GOORAH 2007-05-26 07:30:51 EDT
On the desktop file, Exec=magic -d OGL.

sounds like "magic -d OGL" doesn't like your computer.
On my F7-devel it's working fine.

Try "magic"  only on a terminal and report back if you still have issues with 
it.

Comment 2 Bill Nottingham 2007-05-29 15:30:05 EDT
Correct - magic works, 'magic -d OGL' does not. Other GL apps seem to work fine.
Comment 3 Chitlesh GOORAH 2007-06-21 08:49:58 EDT
can you send a hardware report on what you tried magic ?
Comment 4 Chitlesh GOORAH 2007-06-21 12:02:29 EDT
Fixed and will be available shortly among the updates:
* fc-6
* f-7
* devel

Nevertheless you are requested to test it again. thanks
Comment 5 Bill Nottingham 2007-06-21 13:03:16 EDT
I tried 7.4.35-2.fc7 - it still crashes. x86_64, Radeon R200.
Comment 6 Chitlesh GOORAH 2007-06-21 13:23:01 EDT
actually I changed in the desktop file:
Exec=magic -d OGL
to
Exec=magic

So basically, on startup it shouldn't crash.
But the real bug hasn't yet been fixed and I'll be working with upstream for 
it.

can you specify where it crashes with the 7.4.35-2.fc7 ?
The bug report states on startup. but is it still with 7.4.35-2.fc7 ?
Comment 7 Bill Nottingham 2007-06-21 13:26:41 EDT
It crashes in the same place - glLineWidth() in mesa.
Comment 8 Mamoru TASAKA 2007-06-21 13:33:49 EDT
I have not checked this (and I am not familiar with magic),
however if mesa crashes, it is a bug of mesa IMO.
Comment 9 Chitlesh GOORAH 2007-06-21 13:39:31 EDT
(In reply to comment #8)
> I have not checked this (and I am not familiar with magic),
> however if mesa crashes, it is a bug of mesa IMO.

so
1. Bugzilla Bug 241443: crashes on startup - FIXED

2. it's a mesa bug, should this bug depends on mesa now ?
Comment 10 Mamoru TASAKA 2007-06-21 13:50:45 EDT
IMO now we must change the component of this bug to mesa.
If you agree, I will change.
Comment 11 Chitlesh GOORAH 2007-06-21 13:53:14 EDT
(In reply to comment #10)
> IMO now we must change the component of this bug to mesa.
> If you agree, I will change.

Agree.
Comment 12 Bill Nottingham 2007-06-21 13:54:44 EDT
> 1. Bugzilla Bug 241443: crashes on startup - FIXED

No, it still very much crashes on startup; just not in the default config as
called by the desktop file.

> 2. it's a mesa bug, should this bug depends on mesa now ?

Not necessarily; if you pass bogus pointers to strcmp(), you will crash in libc.
Doesn't mean it's a glibc bug.
Comment 13 Mamoru TASAKA 2007-06-21 14:00:52 EDT
(In reply to comment #12)
> > 2. it's a mesa bug, should this bug depends on mesa now ?
> Not necessarily; if you pass bogus pointers to strcmp(), 
> you will crash in libc.
> Doesn't mean it's a glibc bug.

The reason I say 'IMO it is a bug of mesa' is because *for mesa*
this frequently happens. 
Comment 14 Mamoru TASAKA 2007-06-21 14:01:32 EDT
By the way, have you installed mesa-debuginfo?
Comment 15 Mamoru TASAKA 2007-06-21 14:20:07 EDT
Well, actually according to the initial comment, the point 
where the crash happened is:
--------------------------------------------------------
   303      /* Basic GL parameters */
   304  
   305      glLineWidth(1.0); <- here
--------------------------------------------------------
... I still suspect this is due to mesa bug.
Comment 16 Fedora Update System 2007-06-21 16:06:45 EDT
magic-7.4.35-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.