Bug 241501 - Can't mount SATA drives
Can't mount SATA drives
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-26 16:48 EDT by Dov Grobgeld
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 02:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dov Grobgeld 2007-05-26 16:48:15 EDT
Description of problem:

Trying to mount my SATA drives on my new Gigabyte GA-965G-DS3 motherboard fails.
The drives are accessible from my Windows XP partion including access to its
EXT3 partitions that contain a FC6 installation that was installed from my old
system

Version-Release number of selected component (if applicable):

Linux localhost.localdomain 2.6.20-1.3104.fc7 #1 SMP Sat Apr 21 22:20:43 EDT
2007 i686 i686 i386 GNU/Linux

Gigabyte GA-965G-DS3 motherboard
Intel Duo Core 6600 processor

How reproducible:

Everytime

Steps to Reproduce:

The following steps were pasted from the FC7T3 live CD, that does boot on the
system.

[root@localhost~] fdisk /dev/sda1
Command: p
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3824    30716248+   7  HPFS/NTFS
/dev/sda2            3825        3888      514080   83  Linux
/dev/sda3            3889        5800    15358140   83  Linux
/dev/sda4            5801        9964    33447330    f  W95 Ext'd (LBA)
/dev/sda5            5801        7712    15358108+  83  Linux
/dev/sda6            7713        7864     1220908+  82  Linux swap / Solaris
/dev/sda7            7865        9964    16868218+   b  W95 FAT32

[root@localhost ~]# mkdir /tmp/sda2
[root@localhost ~]# mount /dev/sda2 /tmp/sda2
[root@localhost ~]# 
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: Assertion failure in dx_probe() at fs/ext3/namei.c:384:
"dx_get_limit(entries) == dx_root_limit(dir, root->info.info_length)"
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: ------------[ cut here ]------------
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: invalid opcode: 0000 [#1]
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: SMP 
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: CPU:    1
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: EIP:    0060:[<f8b936f6>]    Not tainted VLI
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: EFLAGS: 00010292   (2.6.20-1.3104.fc7 #1)
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: EIP is at dx_probe+0x175/0x2b9 [ext3]
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: eax: 00000081   ebx: ea8b8418   ecx: c0420cbc   edx: ce63e030
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: esi: eaf72748   edi: efccf298   ebp: f49cccd0   esp: f49ccc94
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: Process trashapplet (pid: 4427, ti=f49cc000 task=ce63e030
task.ti=f49cc000)
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: Stack: f8b9e943 f8b9d89c f8b9e933 00000180 f8b9eab7 ce63e030
00000046 f49ccd78 
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:        eaf72748 00000000 00000167 0ed9017e ebeb9eec eaf72748
ebeb9eec f49ccd9c 
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:        f8b9403f f49ccd60 f49ccd88 dffcd58c ce63e56c 00000246
f49ccdb4 ebeb9eec 
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: Call Trace:
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c04061e9>] show_trace_log_lvl+0x1a/0x2f
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0406299>] show_stack_log_lvl+0x9b/0xa3
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0406459>] show_registers+0x1b8/0x289
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0406657>] die+0x12d/0x242
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0616a07>] do_trap+0x79/0x91
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0406bfa>] do_invalid_op+0x97/0xa1
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c06167dc>] error_code+0x7c/0x84
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<f8b9403f>] ext3_find_entry+0xd2/0x5af [ext3]
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<f8b95966>] ext3_lookup+0x29/0xc7 [ext3]
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0484980>] do_lookup+0xa0/0x13d
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c048674f>] __link_path_walk+0x81f/0xc7a
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0486bf5>] link_path_walk+0x4b/0xc0
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0486f1f>] do_path_lookup+0x191/0x1e2
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c048771a>] __user_walk_fd+0x32/0x44
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c04812d7>] vfs_lstat_fd+0x18/0x3e
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c048133b>] vfs_lstat+0x11/0x13
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0481351>] sys_lstat64+0x14/0x28
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  [<c0405078>] syscall_call+0x7/0xb
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel:  =======================
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: Code: 44 24 10 b7 ea b9 f8 c7 44 24 0c 80 01 00 00 c7 44 24 08
33 e9 b9 f8 c7 44 24 04 9c d8 b9 f8 c7 04 24 43 e9 b9 f8 e8 73 48 89 c7 <0f> 0b
eb fe 8b 45 08 89 45 ec 66 8b 53 02 66 85 d2 74 08 66 39 
Message from syslogd@ at Sat May 26 23:37:05 2007 ...
localhost kernel: EIP: [<f8b936f6>] dx_probe+0x175/0x2b9 [ext3] SS:ESP 0068:f49ccc94


1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The following bugs may be related:

* https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/84964

This problem is a complete showstopper for me as I am currently locked out from
my system.
Comment 1 Chuck Ebbert 2007-05-30 16:29:44 EDT
Looks like a corrupted filesystem?
Please run fsck on the partitions.
Comment 2 Dov Grobgeld 2007-06-04 02:31:06 EDT
Thanks. I had lots of strange errors after buying my new motherboard. But
yesterday everything was solved and I was able to install Fedora 7 on it.

Thanks.
Dov

Note You need to log in before you can comment on or make changes to this bug.