Bug 241613 - alsactl and salsa avc denials during bootup
alsactl and salsa avc denials during bootup
Status: CLOSED DUPLICATE of bug 241497
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 241615 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-28 18:04 EDT by Jakub Hrozek
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 10:49:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2007-05-28 18:04:04 EDT
Description of problem:
I'm seeing lot of avc denied messages upon booting. Everything seems to be 
working normally for me, but I guess it's a sign that something's up :) 
There's about 10 of these messages after the boot:

May 28 22:45:10 localhost kernel: audit(1180385084.803:13): avc:  denied  { 
search } for  pid=1158 comm="alsactl" name="root" dev=dm-0 ino=97345 
scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 
tcontext=system_u:object_r:default_t:s0 tclass=dir

May 28 22:45:10 localhost kernel: audit(1180385084.803:8): avc:  denied  { 
search } for  pid=1158 comm="salsa" name="root" dev=dm-0 ino=97345 
scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 
tcontext=system_u:object_r:default_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.6.4-8.fc7

How reproducible:
Always

Steps to Reproduce:
1. boot the computer
2. look into /var/log/messages to see the denials
  
Actual results:
avc denials for alsactl and salsa

Expected results:
no avc denials

Additional info:
N/A
Comment 1 Daniel Walsh 2007-05-29 11:32:08 EDT
This is caused by an install bug which did not label /root and /home correctly.

restorecon -R -v /root /home

Will fix.

Comment 2 Daniel Walsh 2007-05-29 11:32:54 EDT
*** Bug 241615 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2007-05-31 10:49:10 EDT

*** This bug has been marked as a duplicate of 241497 ***

Note You need to log in before you can comment on or make changes to this bug.