Bug 241686 - RHEL5: Revise EFI version check to not warn on EFI 2.0
RHEL5: Revise EFI version check to not warn on EFI 2.0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Martin Jenner
:
Depends On: 240378
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 11:36 EDT by Prarit Bhargava
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 11:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2007-05-29 11:36:12 EDT
+++ This bug was initially created as a clone of Bug #240378 +++

Description of problem:
Update EFI version check to include EFI 2.0 so that the
EFI version warning is not displayed.   Montvale-based
systems will run EFI 2.0 so this warning would be generated
on every Montvale-based Integrity system.

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Boot 4.5 on an Integrity system with Montvale firmware 
2.
3.
  
Actual results:
the
following warning is output:

Warning: EFI system table major version mismatch: got 2.00, expected 1.00

Expected results:
No warning message is output due to EFI 2.0

Additional info:

See the patch in Issue Tracker # 118636

-- Additional comment from prarit@redhat.com on 2007-05-29 10:51 EST --
Created an attachment (id=155595)
Upstream fix for this issue

Upstream commit for this issue.
Comment 1 Prarit Bhargava 2007-05-29 11:37:23 EDT
Oops.  I was looking at the wrong tree when I opened this BZ.  This code already
exists in RHEL5.

P.

Note You need to log in before you can comment on or make changes to this bug.