Bug 241726 - crash program update needed
Summary: crash program update needed
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Guy Streeter
QA Contact:
URL:
Whiteboard:
Keywords:
: 242869 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-29 20:56 UTC by Guy Streeter
Modified: 2016-02-10 01:32 UTC (History)
3 users (show)

Fixed In Version: RHEL5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 20:04:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Guy Streeter 2007-05-29 20:56:40 UTC
The RHEL5 version of the "crash" (4.0-3.14) program will not work with a 2.6.21
kernel.
I have have done preliminary testing of the 4.0-4.1 version of crash on
kernel-rt-2.6.21-14.el5rt and it seems to work. I don't know if any versions
between the two are sufficient for the 2.6.21 kernel.

(I filed this against "kernel" because we don't have a "crash" component)

Comment 1 Guy Streeter 2007-05-29 20:58:36 UTC
I'll continue testing to make sure the newest version of "crash" will work for
kernel-rt.

Comment 2 Tim Burke 2007-06-07 18:59:34 UTC
*** Bug 242869 has been marked as a duplicate of this bug. ***

Comment 3 john stultz 2007-06-07 21:34:59 UTC
Is there an ETA for the updated crash package to be made available?

Comment 4 Guy Streeter 2007-06-08 16:38:46 UTC
The latest upstream will work. You can build and install
http://people.redhat.com/anderson/crash-4.0-4.2.src.rpm

Getting it into the repo will take a little time.

For i686, see also bug 241810

Comment 5 Guy Streeter 2007-06-11 18:07:28 UTC
The crash maintainer will release 4.0-4.2 or later as a RHEL5 errata "soon."
Since we can build our own from source until then, I think we should forgo
adding crash to our repo.

Comment 6 Guy Streeter 2007-09-13 18:31:09 UTC
crash is apparently not going to be updated for 5.0
The 5.1 beta has crash-4.0-4.3.1


Comment 7 IBM Bug Proxy 2008-02-08 12:58:17 UTC
------- Comment From ankigarg@in.ibm.com 2008-02-08 07:49 EDT-------
Sripathi, yes. The required version of crash tool is available in RHEL5.1. We
can close this bug.


Note You need to log in before you can comment on or make changes to this bug.