Bug 241768 - Windows nx client fails to start session in fedora rawhide
Windows nx client fails to start session in fedora rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nx (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-30 10:26 EDT by Roderick Johnstone
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 11:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log from freenx server (1.99 KB, text/plain)
2007-05-30 10:26 EDT, Roderick Johnstone
no flags Details
Error log from NX client (2.16 KB, text/plain)
2007-05-30 10:27 EDT, Roderick Johnstone
no flags Details

  None (edit)
Description Roderick Johnstone 2007-05-30 10:26:13 EDT
Description of problem:
nx client fails to start session on fedora rawhide system

Version-Release number of selected component (if applicable):
freenx-0.6.0-12.fc7
nx-2.1.0-1.fc6

How reproducible:
Every time.

Steps to Reproduce:
1. Start an nx session to a fedora current rawhide system from a windows nx client
2. 
3.
  
Actual results:
nx client reports:
.
.
Authentication completed.
Connection error.


Expected results:
Running kde session on my Fedora host.
(Same happens with gnome session)

Additional info:
Attached are log files from server and client.

The server reports:
strings: '/usr/libexec/nx/nxagent': No such file
and later
NX> 1004 Error: NX Agent exited with exit status 1.

I've tried clients version 1.5 and 2.1.0-17

The v1.5 client works fine to another system running:
nx-1.5.0-0.FC3.1
freenx-0.4.4-1.fdr.0
on Scientific Linux 4.4.
Comment 1 Roderick Johnstone 2007-05-30 10:26:13 EDT
Created attachment 155687 [details]
Error log from freenx server
Comment 2 Roderick Johnstone 2007-05-30 10:27:18 EDT
Created attachment 155688 [details]
Error log from NX client
Comment 3 Gwyn Ciesla 2007-05-30 11:26:04 EDT
IIRC, the freenx-0.6.0 package was pulled, as it had problems.  Axel, correct me
if I'm wrong, but rpm -e freenx and yum install freenx to 0.5.0 should fix it. 
You might also have to fix the shell path in /etc/passwd for the nx user afterward.
Comment 4 Roderick Johnstone 2007-05-30 11:55:59 EDT
ok so I installed freenx-0.5.0-5.fc6 from the fc6 extras tree.

That gets a little further after I edit the shell path in /etc/passwd to be
/usr/bin/nxserver. It actually starts a session but it closes immediately. The
server log has:

NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 4edd8d932827f1a3431cebdf36885b12
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 4edd8d932827f1a3431cebdf36885b12
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 1009 Session status: starting
NX> 710 Session status: running
NX> 1002 Commit
NX> 1006 Session status: running
NX> 105 bye
Bye
NX> 999 Bye
NX> 1004 Error: NX Agent exited with exit status 1.
NX> 1006 Session status: closed
NX> 596 Session startup failed.
Comment 5 Gwyn Ciesla 2007-05-30 14:57:43 EDT
Hmm, a bit out of my depth.  All I can say is I've been using the current fc6
versions and the Windows NoMachine client 2.1.0-17 sucessfully all day.  With
Gnome, not KDE, but still.  Does the client log have anything new?
Comment 6 Axel Thimm 2007-05-30 19:25:32 EDT
(In reply to comment #3)
> IIRC, the freenx-0.6.0 package was pulled, as it had problems.  Axel, correct me
> if I'm wrong, but rpm -e freenx and yum install freenx to 0.5.0 should fix it. 
> You might also have to fix the shell path in /etc/passwd for the nx user
afterward.

There was a problem with nx providing too much, so nx was pulled. But this has
been fixed for quite some time, but it isn't pushed to the repo for some reason.
Comment 7 Roderick Johnstone 2007-05-31 08:09:02 EDT
With regard to comment #5, 0.5.0 fails in the same way for me with a gnome or
kde sesion. I didnt rebuild the rpm though. Maybe that is an issue? I haven't
been able to see any client messages as the client windows all disappear.
Comment 8 Axel Thimm 2007-05-31 19:03:52 EDT
Please try the freenx/nx packages at ATrpms which are identical to the ones that
wait in the queue here.
Comment 9 Roderick Johnstone 2007-05-31 19:34:27 EDT
Well using those packages I get the same style failure as using the 0.5.0 from
the  fc6 distribution. ie It starts the session but the session is terminated
and the client exits almost immediately. Will investigate logs when I have a
little more time.
Comment 10 Axel Thimm 2007-06-03 04:19:13 EDT
These packages are also available in updates and updates-testing now, but the
functionality is the same, so don't expect the issue to go away by upgrading to
them.

I also assume that your using F7 now and not anymore rawhide, is that correct? I
cahnged the version field already, so if I'm wrong, please change it back.
Comment 11 Roderick Johnstone 2007-06-04 12:23:51 EDT
I'm not seeing them on my mirror yet but I'll confirm the problem against the F7
release when they turn up.
Comment 12 Roderick Johnstone 2007-06-06 11:53:24 EDT
freenx-0.6.0-12.fc7 and nx-2.1.0-22.fc7 seem to work well for me now on an f7
system.

I found a typo in my /etc/nxserver/node.conf file that was certainly messing
things up, but I dont think that was the cause of the original report including
the message:

strings: '/usr/libexec/nx/nxagent': No such file

Maybe that was fixed with the new nx package from updates - I'm not sure.


Note You need to log in before you can comment on or make changes to this bug.