Bug 241787 - lvm mirror creation can sometimes fail and only creates a log device
lvm mirror creation can sometimes fail and only creates a log device
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
Corey Marthaler
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-30 12:35 EDT by Corey Marthaler
Modified: 2007-11-16 20:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 06:37:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2007-05-30 12:35:35 EDT
Description of problem:
This has been seen and discussed before, but I couldn't find a rhel4 bug for
this issue. There is a rhel5 bug for it however (bz 204143).

I'm not sure how to get into this state, but I believe it has to do with using
the same vg name as one that had previously been marked inconsistent.

[root@link-02 ~]# pvs
  PV         VG         Fmt  Attr PSize   PFree
  /dev/hda2  VolGroup00 lvm2 a-    37.16G  32.00M
  /dev/sda1  corey      lvm2 a-   135.66G 135.66G
  /dev/sdb1  corey      lvm2 a-   135.66G 135.66G
  /dev/sdc1  corey      lvm2 a-   135.66G 135.66G
  /dev/sdd1  corey      lvm2 a-   135.66G 135.66G
  /dev/sde1  corey      lvm2 a-   135.66G 135.66G
  /dev/sdf1  corey      lvm2 a-   135.66G 135.66G
  /dev/sdg1  corey      lvm2 a-   135.66G 135.66G
[root@link-02 ~]# vgs
  VG         #PV #LV #SN Attr   VSize   VFree
  VolGroup00   1   2   0 wz--n-  37.16G  32.00M
  corey        7   0   0 wz--n- 949.59G 949.59G
[root@link-02 ~]# lvs
  LV       VG         Attr   LSize  Origin Snap%  Move Log Copy%
  LogVol00 VolGroup00 -wi-ao 35.19G
  LogVol01 VolGroup00 -wi-ao  1.94G
[root@link-02 ~]# dmsetup ls
VolGroup00-LogVol01     (253, 1)
VolGroup00-LogVol00     (253, 0)
[root@link-02 ~]# lvcreate -m 2 -n mirror1 -L 3G corey
  Aborting. Failed to activate mirror log. Remove new LVs and retry.
  Failed to create mirror log.
[root@link-02 ~]# dmsetup ls
VolGroup00-LogVol01     (253, 1)
VolGroup00-LogVol00     (253, 0)
[root@link-02 ~]# lvs
  LV           VG         Attr   LSize  Origin Snap%  Move Log Copy%
  LogVol00     VolGroup00 -wi-ao 35.19G
  LogVol01     VolGroup00 -wi-ao  1.94G
  mirror1_mlog corey      -wi---  4.00M



Version-Release number of selected component (if applicable):
2.6.9-55.ELlargesmp
lvm2-2.02.21-5.el4

How reproducible:
Everytime, once in this state.
Comment 1 Corey Marthaler 2007-05-30 16:35:03 EDT
Although, I do see this issue from time to time, in this case it was due to the
tags that I had added to the devices. I'll close this bug and reopen when I can
reproduce in a normal setting.

Note You need to log in before you can comment on or make changes to this bug.