Bug 241832 - X crashes when LCD brightness is changed
X crashes when LCD brightness is changed
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-30 18:47 EDT by Julian Sikorski
Modified: 2007-12-10 06:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 06:38:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.conf file (1.03 KB, text/plain)
2007-05-30 18:51 EDT, Julian Sikorski
no flags Details
Xorg.0.log, recorded with startx -- -logverbose 5 (44.40 KB, text/plain)
2007-05-30 19:20 EDT, Julian Sikorski
no flags Details

  None (edit)
Description Julian Sikorski 2007-05-30 18:47:06 EDT
Description of problem:
Whenever LCD brightness is changed while in X server, it will cause it to crash.
 Works perfectly from the console.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-47.8.fc6.x86_64
xorg-x11-drv-jamstudio-1.1.0-1.1.x86_64
xorg-x11-drivers-7.1-3.x86_64
xorg-x11-drv-void-1.1.0-3.1.x86_64
xorg-x11-drv-i810-1.6.5-10.fc6.x86_64
xorg-x11-drv-magictouch-1.0.0.5-2.1.x86_64
xorg-x11-drv-s3-0.5.0-1.fc6.x86_64
xorg-x11-drv-savage-2.1.1-5.fc6.x86_64
xorg-x11-drv-cirrus-1.1.0-2.fc6.x86_64
xorg-x11-fonts-misc-7.1-2.noarch
xorg-x11-xfs-1:1.0.2-3.1.x86_64
xorg-x11-fonts-100dpi-7.1-2.noarch
xorg-x11-drv-nvidia-devel-1.0.9755-4.lvn6.x86_64
xorg-x11-drv-nvidia-libs-32bit-1.0.9755-4.lvn6.x86_64
xorg-x11-server-utils-7.1-4.fc6.x86_64
xorg-x11-drv-vmware-10.13.0-2.1.x86_64
xorg-x11-xdm-1:1.0.5-5.fc6.x86_64
xorg-x11-drv-dynapro-1.1.0-2.x86_64
xorg-x11-drv-aiptek-1.0.1-2.x86_64
xorg-x11-filesystem-7.1-2.fc6.noarch
xorg-x11-drv-nv-1.2.0-4.fc6.x86_64
xorg-x11-drv-joystick-1.1.0-1.1.x86_64
xorg-x11-xtrans-devel-1.0.1-1.1.fc6.i386
xorg-x11-drv-dmc-1.1.0-2.x86_64
xorg-x11-drv-sisusb-0.8.1-4.1.x86_64
xorg-x11-drv-summa-1.1.0-1.1.x86_64
xorg-x11-font-utils-1:7.1-2.x86_64
xorg-x11-utils-7.1-2.fc6.x86_64
xorg-x11-drv-acecad-1.1.0-2.1.x86_64
xorg-x11-fonts-75dpi-7.1-2.noarch
xorg-x11-drv-vga-4.1.0-2.1.x86_64
xorg-x11-drv-mga-1.4.5-2.fc6.x86_64
xorg-x11-drv-vmmouse-12.4.0-2.1.x86_64
xorg-x11-drv-s3virge-1.9.1-2.1.x86_64
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2.noarch
xorg-x11-proto-devel-7.1-9.fc6.x86_64
xorg-x11-xkb-utils-1.0.2-2.1.x86_64
xorg-x11-drv-magellan-1.1.0-1.1.x86_64
xorg-x11-drv-voodoo-1.1.0-3.1.x86_64
xorg-x11-fonts-truetype-7.1-2.noarch
xorg-x11-drv-fpit-1.1.0-1.1.x86_64
xorg-x11-docs-1.2-4.fc6.noarch
xorg-x11-apps-7.1-3.fc6.x86_64
xorg-x11-drv-ur98-1.1.0-1.1.x86_64
xorg-x11-xtrans-devel-1.0.1-1.1.fc6.x86_64
xorg-x11-drv-via-0.2.1-7.x86_64
xorg-x11-drv-calcomp-1.1.0-1.1.x86_64
xorg-x11-drv-elo2300-1.1.0-1.1.x86_64
xorg-x11-drv-nvidia-1.0.9755-4.lvn6.x86_64
xorg-x11-drv-mutouch-1.1.0-2.x86_64
xorg-x11-drv-citron-2.2.0-1.1.x86_64
xorg-x11-drv-ati-6.6.3-1.fc6.x86_64
xorg-x11-drv-tdfx-1.3.0-2.fc6.x86_64
xorg-x11-drv-palmax-1.1.0-1.1.x86_64
xorg-x11-util-macros-1.0.2-4.fc6.x86_64
xorg-x11-drv-elographics-1.1.0-1.1.x86_64
xorg-x11-twm-1:1.0.1-3.1.x86_64
xorg-x11-drv-digitaledge-1.1.0-1.1.x86_64
xorg-x11-fonts-Type1-7.1-2.noarch
xorg-x11-drv-spaceorb-1.1.0-1.1.x86_64
xorg-x11-drv-sis-0.9.1-7.x86_64
xorg-x11-drv-ast-0.81.0-3.x86_64
xorg-x11-drv-hyperpen-1.1.0-2.x86_64
xorg-x11-xauth-1:1.0.1-2.1.x86_64
xorg-x11-fonts-base-7.1-2.noarch
xorg-x11-xinit-1.0.2-15.fc6.x86_64
xorg-x11-drv-siliconmotion-1.4.1-2.1.x86_64
xorg-x11-drv-mouse-1.2.1-1.fc6.x86_64
xorg-x11-drv-keyboard-1.1.0-2.1.x86_64
xorg-x11-drv-evdev-1.1.2-2.1.x86_64
xorg-x11-drv-dummy-0.2.0-2.1.x86_64
xorg-x11-drv-microtouch-1.1.0-1.1.x86_64
xorg-x11-drv-vesa-1.2.1-4.x86_64
xorg-x11-drv-fbdev-0.3.0-2.x86_64
xorg-x11-drv-penmount-1.1.0-2.1.x86_64
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.noarch
xorg-x11-drv-trident-1.2.3-1.fc6.x86_64

How reproducible:
always

Steps to Reproduce:
1. get a Toshiba Satellite A100-847 laptop
2. boot into X server
3. press fn-f6 or fn-f7
  
Actual results:
brightness changes, but X crashes

Expected results:
X does not crash

Additional info:
I have bios version 5.60 here. A100-847 is a european laptop with Phoenix BIOS,
GeForce Go 7600 GPU and Core2Duo T7200 CPU.
/proc/acpi/video/VGA/LCD/brightness does not reflect the changes at all.
Comment 1 Julian Sikorski 2007-05-30 18:51:58 EDT
Created attachment 155755 [details]
My xorg.conf file
Comment 2 Julian Sikorski 2007-05-30 18:59:26 EDT
FYI: crash happens with open driver as well.
Comment 3 Matěj Cepl 2007-05-30 19:06:57 EDT
Could we get a log of the reproduction of the problem with "nv" driver? Sorry,
we don't support nvidia drivers and without reproduction in "nv" (with log) I
would have to close the bug.
Comment 4 Julian Sikorski 2007-05-30 19:19:27 EDT
I understand you don't support binary blobs, that's why I tried to reproduce the
crash with nv driver.
Comment 5 Julian Sikorski 2007-05-30 19:20:32 EDT
Created attachment 155756 [details]
Xorg.0.log, recorded with startx -- -logverbose 5
Comment 6 Julian Sikorski 2007-06-01 14:47:25 EDT
I upgraded to Fedora 7 and both drivers work. I guess the problem must have been
lying elsewhere.
Comment 7 Matěj Cepl 2007-06-01 20:18:48 EDT
Thanks a lot, but that means, that the bug is probably still present in FC6.
Comment 8 Matěj Cepl 2007-12-10 04:24:06 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Note You need to log in before you can comment on or make changes to this bug.