Bug 241845 - pdf conversion improperly escapes characters
pdf conversion improperly escapes characters
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: docbook-utils (Show other bugs)
5.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 00:57 EDT by Steve Dum
Modified: 2011-08-25 04:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-25 04:55:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug.xml - test case (1.12 KB, text/xml)
2007-05-31 00:57 EDT, Steve Dum
no flags Details
jw log (6.37 KB, application/octet-stream)
2008-01-26 16:07 EST, Steve Dum
no flags Details

  None (edit)
Description Steve Dum 2007-05-31 00:57:58 EDT
Description of problem: The character sequence backslash poundsign 
doesn't get properly escaped causing jw's xml to pdf conversion to emit
lots of error messages and fail to generate the pdf


Version-Release number of selected component (if applicable):

docbook-utils-0.6.14-5.1
docbook-utils-0.6.13-5


How reproducible:
always

Steps to Reproduce:
1. jw -f docbook -b html -V nochunks bug.xml
   works ok, no errors
2.jw -f docbook -b pdf bug.xml
  fails
Source file bug.xml attached
Additional info:
Note: fails on RHEL3, RHEL5 and FC6
Comment 1 Steve Dum 2007-05-31 00:57:58 EDT
Created attachment 155779 [details]
bug.xml - test case
Comment 2 Ondrej Vasik 2007-06-04 03:07:41 EDT
Because of low priority and severity I suggest to move RHEL version for fix to 5
- there will be no RHEL 3.10 and this problem will not get to 3.9 or standalone
security patch for RHEL 3.
Comment 3 Ondrej Vasik 2007-11-29 08:32:04 EST
Just want to mention that the problem is most probably not in docbook-utils
package, because on my machine with other later docbook packages it works with
RHEL-5 and FC-6 docbook-utils without troubles. Will try to find something more
and possibly reassign the problem...
Comment 4 RHEL Product and Program Management 2007-12-03 15:43:10 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 5 Ondrej Vasik 2008-01-26 15:02:51 EST
As I said, I'm still not able to reproduce the problem with docbook-utils you
mentioned... pdf processed without errors... could you please specify following
things:
1) rpm -q docbook-style-xsl 
2) Have you tried F8/RAWHIDE docbook packages?
3) Could you please attach log with the error messages? 

Thanks in advance.
Comment 6 Steve Dum 2008-01-26 16:07:45 EST
Created attachment 293063 [details]
jw log
Comment 7 Steve Dum 2008-01-26 16:12:39 EST
I retried the example with fecora 8.
p% rpm -q docbook-style-xsl 
docbook-style-xsl-1.73.2-3.fc8

One difference with F8 is that the pdf is generated with correct results dispite
a few hundred lines of error messages.  log file of the jw command attached.
Comment 8 Ondrej Vasik 2011-08-25 04:55:07 EDT
Cleaning up old bugzillas... as sgml branch of tools is much less in use nowadays I doubt this is worth of further investigation - especially if it is "only" producing non critical error messages and pdf is correctly generated. Closing WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.