Bug 241873 - /etc/Muttrc contains version string
Summary: /etc/Muttrc contains version string
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-31 11:01 UTC by Stepan Kasal
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 13:20:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the diff (1.54 KB, text/x-patch)
2007-05-31 11:01 UTC, Stepan Kasal
no flags Details

Description Stepan Kasal 2007-05-31 11:01:06 UTC
Description of problem:
/etc/Muttrc contains the version number 6 times, and it is updated each time a
new version is used.
Since /etc/Muttrc is a config file, and the user may have modified it, this
unnnecessary change makes the diff longer and presents extra work during the
upgrade.  See the attached diff.

I suggest to create a symlink to the directory, either /usr/share/doc/mutt, or
/usr/share/mutt

Comment 1 Stepan Kasal 2007-05-31 11:01:07 UTC
Created attachment 155794 [details]
the diff

Comment 2 Miroslav Lichvar 2007-05-31 14:05:42 UTC
Yes, /etc/Muttrc is marked as a config file, but /etc/Muttrc.local should be
used for local changes.

Since /etc/Muttrc has also listed all available options with descriptions it's
likely that a newer version will have more changes in the file than just the
version strings.

The lynx package has a similar setup.

Comment 3 Stepan Kasal 2007-06-11 13:20:32 UTC
OK Miroslav, I admit there is no real need to change the current setup, closing.
Thanks for your time.


Note You need to log in before you can comment on or make changes to this bug.