Bug 241897 - Installing selinux-policy-targeted prints error
Installing selinux-policy-targeted prints error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
: 241914 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 11:07 EDT by Adam Tkac
Modified: 2013-04-30 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 04:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2007-05-31 11:07:34 EDT
Description of problem:
When I updating my rawhide system I got this message:

 Updating  : selinux-policy-targeted      ##################### [ 83/317]
usage:  /sbin/setfiles [-dnpqvW] [-o filename] [-r alt_root_path ] spec_file
pathname...
usage:  /sbin/setfiles -c policyfile spec_file
usage:  /sbin/setfiles -s [-dnqvW] [-o filename ] spec_file
libsemanage.semanage_install_active: setfiles returned error code 1.
libsepol.sepol_genbools_array: boolean httpd_can_sendmail no longer in policy
usage:  /sbin/setfiles [-dnpqvW] [-o filename] [-r alt_root_path ] spec_file
pathname...
usage:  /sbin/setfiles -c policyfile spec_file
usage:  /sbin/setfiles -s [-dnqvW] [-o filename ] spec_file
libsemanage.semanage_install_active: setfiles returned error code 1.
semodule:  Failed! 

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.6.5-2.fc8

How reproducible:
always

Steps to Reproduce:
1. install selinux-policy-targeted-2.6.5-2.fc8
  
Actual results:
error message

Expected results:
no error
Comment 1 Michal Jaegermann 2007-05-31 18:13:26 EDT
As a matter of fact with policycoreutils-2.0.19-1.fc8 in place doing
the following small fragment of selinux-policy-targeted %post:

cd /usr/share/selinux/targeted
semodule -b base.pp -i rpcbind.pp -s targeted

is causing the same "usage:" response.  /usr/sbin/semodule is binary
so apparently the way it calls /sbin/setfiles makes the later unhappy.
Comment 2 Daniel Walsh 2007-06-01 14:04:26 EDT
*** Bug 241914 has been marked as a duplicate of this bug. ***
Comment 3 Adam Tkac 2007-07-18 04:51:18 EDT
Looks like fixed

Adam

Note You need to log in before you can comment on or make changes to this bug.