Bug 24196 - "xfs" installed and started even with no X installed
"xfs" installed and started even with no X installed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-16 23:55 EST by Chris Adams
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-20 14:24:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2001-01-16 23:55:05 EST
I did a minimal "Custom" install (basically for a home gateway router) with
very little installed (no X at all).  However, xfs was still installed and
started automatically at boot.  If X is not installed, xfs should not be
installed or started by default.
Comment 1 Glen Foster 2001-01-17 13:20:44 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Mike A. Harris 2001-01-20 03:41:12 EST
xfs is *not* dependant on XFree86 being installed.  xfs can be installed
on a machine on a network and used simply as a networked font server without
having XFree86 installed.  The XFree86-xfs package is required however by
the packages chkfontpath, kdebase, Xconfigurator, and XFree86 itself,
and I believe possibly by other packages also.  If you have elected to
install any of the above mentioned packages, they will drag in xfs as
it is needed (or something included in it is needed) for proper operation
of the above packages.  If you do not need xfs, and do not need the above
listed packages either, then make sure you unselect them and any other
dependant packages during the custom install, and do not choose
"automatically install all dependancies".

I will look into why xfs service is being started at boot even if it
isn't required though, as that sounds like a reasonable concern indeed.


Comment 3 Chris Adams 2001-01-20 14:24:29 EST
Okay, it appears that Xfree86-xfs was installed because I selected
"Printer Support".  I have a PostScript printer, so I don't need
Ghostscript, but rhs-printfilters pulls in ghostscript, which pulls in
Xfree86-libs, several font packages, chkfontpath, and XFree86-xfs.

The only way I can think of to not have xfs start at boot in this setup
would be to have the XFree86-xfs package not install it as starting by
default.  Then have the XFree86 package "chkconfig xfs on", but that
would require that XFree86-xfs package be installed before XFree86.

I still miss the feature of older Red Hat installers that allowed you to
select the services to start at boot during configuration.  Any chance
of bringing this back?  Maybe service configuration could be in a
section of the RPM file and the comps file, so it could be done before
install.
Comment 4 Mike A. Harris 2001-01-28 04:02:17 EST
Fixed in Rawhide.  xfs will check for the existance of an X server
installation during initscript processing.  If no X server is installed,
xfs will not start.

Note You need to log in before you can comment on or make changes to this bug.