Bug 241991 - upgrade_bootloader_gui.py demands "full" /etc/modprobe.conf
upgrade_bootloader_gui.py demands "full" /etc/modprobe.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 241992 242286 242393 243121 243789 244124 436700 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 02:01 EDT by Anduin Withers
Modified: 2008-03-10 09:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 11:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anduin Withers 2007-06-01 02:01:16 EDT
Description of problem:

The _newToLibata function is broken, it attempts to l.strip()[0] == "#" 
(upgrade_bootloader_gui.py: 78). The problem with this is clear, a stripped 
empty line will "IndexError: string index out of range".

How reproducible:

Very, easily.

Steps to Reproduce:

1. Upgrade a real system, especially one with at least one blank line 
in /etc/modprobe.conf
  
Actual results:

Failed upgrade.

Expected results:

The upgrade to succeed.

Additional info:
Comment 1 Anduin Withers 2007-06-01 05:36:41 EDT
*** Bug 241992 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2007-06-01 11:39:21 EDT
This will be fixed in the next build of anaconda.  We may also be putting
together an updates.img for this and several other issues that will allow you to
use the F7 installer to upgrade.  I'll update this bug when we do that.
Comment 3 Chris Lumens 2007-06-04 10:00:33 EDT
*** Bug 242393 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2007-06-04 10:01:07 EDT
*** Bug 242286 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2007-06-06 13:47:20 EDT
This bug is now addressed by an updates image.  It is available for download at:

    http://people.redhat.com/clumens/f7-updates.img

Instructions for using updates disks are located at:

    http://fedoraproject.org/wiki/Anaconda/Updates

If possible, please test this image out and report if it fixes your issue or
not.  Once we are confident that your issue is solved by this image, we are
going to announce it more publicly.  This fix may also be included in an updated
anaconda package later for people who are making custom Fedora distributions. 
Thanks for your time.
Comment 6 Chris Lumens 2007-06-07 10:09:47 EDT
*** Bug 243121 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Woick 2007-06-07 11:28:11 EDT
The f7-updates.img from comment #5 works fine for me. Thanks!

By the way, I did not find this bug, although I thought I searched very
thoroughly for anaconda bugs in f7. It should perhaps be pointed out to the
novice user like me, that he should include CLOSED bugs into into search. It may
be not so obvious.
Comment 8 Chris Lumens 2007-06-12 09:56:49 EDT
*** Bug 243789 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2007-06-14 09:39:39 EDT
*** Bug 244124 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2008-03-10 09:29:46 EDT
*** Bug 436700 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.