Bug 241992 - upgrade_bootloader_gui.py expects no blank lines in /etc/modprobe.conf
upgrade_bootloader_gui.py expects no blank lines in /etc/modprobe.conf
Status: CLOSED DUPLICATE of bug 241991
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2007-06-01 02:05 EDT by Anduin Withers
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-01 05:36:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anduin Withers 2007-06-01 02:05:07 EDT
Description of problem:

The _newToLibata function is broken, it attempts to l.strip()[0] == "#" 
(upgrade_bootloader_gui.py: 78). The problem with this is clear, a stripped 
empty line will "IndexError: string index out of range".

Version-Release number of selected component (if applicable):

How reproducible:
Very, easily.

Steps to Reproduce:
1. Actually upgrade a real system, especially one with at least one blank line 
in /etc/modprobe.conf.
Actual results:

Upgrade fails.

Expected results:

Upgrade to work.

Additional info:
Comment 1 Anduin Withers 2007-06-01 05:36:38 EDT

*** This bug has been marked as a duplicate of 241991 ***

Note You need to log in before you can comment on or make changes to this bug.