Bug 24201 - Installer crashes if you switch away from X
Installer crashes if you switch away from X
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-17 02:31 EST by Edward Kuns
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 12:24:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 2001-01-17 02:31:47 EST
Ok, this isn't a biggie in terms of bugs, but after the install starts
copying files to disk, if you ALT-CTRL-F2 away from the X installer
window, the install will eventually crash.
Comment 1 Glen Foster 2001-01-17 13:16:49 EST
This defect is considered MUST-FIX for Florence Beta-3
Comment 2 Michael Fulbright 2001-01-17 13:26:14 EST
What video card were you using?
Comment 3 Edward Kuns 2001-01-18 09:56:51 EST
Creative Labs Annhilator 2 GTS ... I'll provide more information
tonight on what it is detected as and such.  Let me know if you
need more information such as lspci output.
Comment 4 Michael Fulbright 2001-01-18 11:47:22 EST
lspci -n is helpful.

Do you know which chipset is on the card?
Comment 5 Edward Kuns 2001-01-19 11:01:05 EST
lspci -n output:

00:00.0 Class 0600: 1106:0305 (rev 03)
00:01.0 Class 0604: 1106:8305
00:07.0 Class 0601: 1106:0686 (rev 22)
00:07.1 Class 0101: 1106:0571 (rev 10)
00:07.2 Class 0c03: 1106:3038 (rev 10)
00:07.3 Class 0c03: 1106:3038 (rev 10)
00:07.4 Class 0600: 1106:3057 (rev 30)
00:0b.0 Class 0100: 10cd:2300
00:0d.0 Class 0200: 100b:0020
00:0f.0 Class 0401: 1102:0002 (rev 04)
00:0f.1 Class 0980: 1102:7002 (rev 01)
00:11.0 Class 0200: 1317:0985 (rev 11)
00:13.0 Class 0180: 1103:0004 (rev 03)
01:00.0 Class 0300: 10de:0150 (rev a3)

lspci -v for the video card:

01:00.0 VGA compatible controller: nVidia Corporation NV15 (Geforce2 GTS) (rev
a3) (prog-if 00 [VGA])
        Subsystem: Creative Labs: Unknown device 1047
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 9
        Memory at dc000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [60] Power Management version 1
        Capabilities: [44] AGP version 2.0

and for thoroughness, here is a piece of the XFree86 startup from
*after* a successful install.  (This text isn't from an install!)

XFree86 Version 4.0.2 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 18 December 2000
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.17-8smp i686 [ELF] 
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Jan 18 19:05:33 2001
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "Anaconda Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "NVIDIA GeForce 2 (generic)"
Comment 6 Michael Fulbright 2001-01-19 12:23:58 EST
How would we reproduce this issue? I'm not seeing this problem with a Geforce
256 card (admittadly a older nVidia card).
Comment 7 Michael Fulbright 2001-01-19 12:48:49 EST
I have tested a card with the same PCI id and do not see this problem. Will wait
for feedback from user on how to reproduce issue.
Comment 8 Edward Kuns 2001-01-28 19:11:26 EST
I have finally figured out what I did to cause this.  It took a lot of
experimentation before I could reproduce it.  Having reproduced it,
I have a much better idea of what is going on!

I choose all the defaults and let the installer start installing
packages.  Then I CTRL-ALT-F2 to switch to the shell.  In the shell, I:

     cd /mnt/source

and I wait.  The installer will die, hard.  The first time this
happened, I was poking around to see what was mounted, etc, while
the install was going on.  I've seen it die in a couple different
ways.  In one, the machine just hangs.  CTRL-ALT-DEL does nothing.
In the other, the installer complaints and quits gracefully,
unloading all the disks and all like it does when an install is
over.

Just poking around in the various mounted file systems and
cd-ing around causes this to happen.

OK, I just reproduced the whole thing again.  Right after the
installer starts copying files, I went to the shell window
and entered:

     cd /mnt/source

and then later,

     df

and after a while, the installer switched me back to console
one, showing the following:

shutting down
shut down
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...

and so on.
Comment 9 Michael Fulbright 2001-01-29 19:49:50 EST
Thanks, assigning to a developer.
Comment 10 Glen Foster 2001-01-30 15:49:05 EST
This defect is now considered MUST-FIX for Florence Release-Candidate #1
Comment 11 Brent Fox 2001-02-09 15:18:48 EST
I too am unable to reproduce this problem.  There must be some weirdness in the
hardware.
Comment 12 Edward Kuns 2001-02-12 15:57:04 EST
Is there anything I can do to provide more debugging information?
Or could you perhaps make a version of the installer which will
display more debugging information so we could narrow down where
it is failing?

I have a cable modem, so I'm able to download and burn CD's, if that
is required.

Note You need to log in before you can comment on or make changes to this bug.