Bug 242026 - Xorg does not work with nv driver on Geforce Go 7600
Xorg does not work with nv driver on Geforce Go 7600
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Depends On:
  Show dependency treegraph
Reported: 2007-06-01 07:32 EDT by Lukas Middendorf
Modified: 2008-05-14 09:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-14 09:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X logfile (42.76 KB, text/plain)
2007-06-01 07:32 EDT, Lukas Middendorf
no flags Details
xorg.conf (838 bytes, text/plain)
2007-06-01 07:34 EDT, Lukas Middendorf
no flags Details
console-output of Xorg -configure (1.43 KB, text/plain)
2007-06-05 04:01 EDT, Lukas Middendorf
no flags Details
xorg.conf from Xorg -configure (2.39 KB, text/plain)
2007-06-05 04:04 EDT, Lukas Middendorf
no flags Details
Xorg.0.log from running X with the generated xorg.conf (40.77 KB, text/plain)
2007-06-05 04:07 EDT, Lukas Middendorf
no flags Details
xorg-logfile from running "Xorg" without xorg.conf (45.93 KB, text/plain)
2007-09-04 17:37 EDT, Lukas Middendorf
no flags Details
Xorg logfile from F8test3 live (43.17 KB, text/plain)
2007-10-08 04:39 EDT, Lukas Middendorf
no flags Details

  None (edit)
Description Lukas Middendorf 2007-06-01 07:32:01 EDT
Description of problem:
When Xorg starts up, only a blank screen is shown (sometimes there are some 
colored pixels, but nothing useful; I even had a red screen once). Problem 
occurs with rhgb, anaconda, firstboot and the normal xorg.conf. Killing X with 
ctrl+alt+backspace does not change the situation.
On text console white stripes on black background are shown with some white or 
black boxes where characters should be. If I log in as root (did not try as 
normal user) this distortion disappears.

I have the same Problem with the live-CD. 

I am running on an Acer Aspire 5652 Notebook with a Geforce Go 7600 Graphics 

Version-Release number of selected component (if applicable):
everything as shiped on F7-isos
Same Problem also with up to date FC6

How reproducible:
problem occurs every time

Steps to Reproduce:
1. Just let X start
Actual results:
Screen becomes blank and does not show anything useful

Expected results:
X should be useable

Additional info:

As there is an error related to aiglx in the logfile, I tried to disable it 
Section "ServerFlags"
        Option  "AIGLX" "off"
but despites the fact that the error went away, nothing changed.

The Problem does not occur when the proprietary nvidia driver from livna is 
installed and activated.

While investigating the Problem I recognized, that it also occurs with FC6 
(same effects) when I disable the proprietary nvidia driver. I don't know how 
long the Problem exists.
Comment 1 Lukas Middendorf 2007-06-01 07:32:02 EDT
Created attachment 155870 [details]
X logfile
Comment 2 Lukas Middendorf 2007-06-01 07:34:01 EDT
Created attachment 155871 [details]
Comment 3 David 2007-06-03 19:44:04 EDT
I just found this bug, it look similar as my bug.  Can you try the Xorg
-configure and see if you get the same results?


Comment 4 Lukas Middendorf 2007-06-05 03:59:15 EDT
OK, I tried Xorg -configure and I got a (working) xorg.conf with proprietary 
nvidia-driver enabled. So I removed rpms from livna, rebooted and tried again.
Now I get a xorg.conf with the "nouveau" driver enabled. When I try to start X 
with this new config I just get the known black screen (now with some pink 
pixels) and the distorted console again.
If I try to change
Driver      "nouveau"
Driver      "nv"
I get the same result (just without the pink pixels)
Comment 5 Lukas Middendorf 2007-06-05 04:01:25 EDT
Created attachment 156184 [details]
console-output of Xorg -configure

This is the output whithout the proprietary driver installed. As far as I can
remember it was the same when the driver was installed.
Comment 6 Lukas Middendorf 2007-06-05 04:04:52 EDT
Created attachment 156185 [details]
xorg.conf from Xorg -configure
Comment 7 Lukas Middendorf 2007-06-05 04:07:36 EDT
Created attachment 156186 [details]
Xorg.0.log from running X with the generated xorg.conf
Comment 8 Matěj Cepl 2007-09-04 08:05:24 EDT
Xorg -configure is kind of ancient method. Could you please try to run Xorg
without any /etc/X11/xorg.conf whatsoever? Autodetection should do something
nice for you? Please, attach log file from that attempt whatever happens. If
that doesn't work, than it is bug and we have to do something about it -- it
should work.

Older (but still better than Xorg -configure) is system-config-display. Try to
run it and configure your display. Or did you do it before? If not, then again
logs would be helpful.
Comment 9 Lukas Middendorf 2007-09-04 17:37:25 EDT
Created attachment 186691 [details]
xorg-logfile from running "Xorg" without xorg.conf
Comment 10 Lukas Middendorf 2007-09-04 17:44:07 EDT
I removed the nvidia-driver-packages from livna for testing.
I have tried to run "Xorg" without xorg.conf, resulting in the known black 
oder purple screen and the distortion of the console (revert to normal through 
normal login in a different console).

system-config-display only brought me a black screen and no usable log-output 
(/etc/X11/Xorg.setup.log just says It uses a config file in /tmp but I did not 
find it, even with system-config-display still running).
Comment 11 Matěj Cepl 2007-09-05 10:41:24 EDT
That should be enough. Passing to developers.
Comment 12 Lukas Middendorf 2007-10-08 04:39:00 EDT
Created attachment 219081 [details]
Xorg logfile from F8test3 live

I have tested this issue again with F8 test3 (live CD) and mothing seems
changed (except that I have seen a completely YELLOW screen for rhgb this
time). When starting without rhgb, everything seems to be the same as in F7, I
have the logfile attached cause it has some differences to the ones from F7
(but maybe it is just because the live CD has less packages included than my F7
system on the harddrive).
Comment 13 Bug Zapper 2008-05-14 08:42:34 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Lukas Middendorf 2008-05-14 09:37:39 EDT
I made further investigations on this and it seems to have been related to a 
corrupted VGA-bios. Didn't retest with fedora, but after flashing the bios 
this problem disappeared in anaconda (f7) and ubuntu (was the same problem 

Note You need to log in before you can comment on or make changes to this bug.