Bug 242030 - Wrong keyboard layout names
Wrong keyboard layout names
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 08:10 EDT by Stepan Kasal
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 11:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.08 KB, patch)
2007-06-01 08:10 EDT, Stepan Kasal
no flags Details | Diff

  None (edit)
Description Stepan Kasal 2007-06-01 08:10:15 EDT
The list of keyboard layouts in config-system-keyboard contains these
  Czechoslovakian (qwertz)
  Czechoslovakian
  Slovakian

First, there is no such keyboard.  In the area of former Czechoslovakia, two
distinct languages (and thus typewriter keyboard layouts) were used: Czech and
Slovak.
Both were "qwertz-type," because the first typewriters were imported from
Germany, and the German language was heavily used in the former Austrian empire.
And both languages still have qwertz layout as official standard.

Two fixes are needed:
  correct language names
  default is "qwertz", "qwerty" is a variant.
IOW, the keyboard layout names have to be changed to:
  Czech
  Czech (qwerty)
  Slovak (qwerty)

OTOH, I don't think it's a big deal if the "querty" variant would be preset as
default.  (At least not until Fedora is heavily used by Office Assistants. ;-)

Likewise, I do not think that the lack of a standard Slovak keyboard is an
urgent problem.  Let's wait for another bug report. ;-)

Attached please find a proposed patch.
Comment 1 Stepan Kasal 2007-06-01 08:10:15 EDT
Created attachment 155872 [details]
proposed patch
Comment 2 Chris Lumens 2007-06-01 11:09:23 EDT
Ah, thanks for the patch and the information.  Good to see that we'll no longer
be offering a layout named after a country that hasn't existed for many years
now.  The problem with these sorts of bugs is that they just don't ever get
discovered until after a release because none of the anaconda developers are
familiar with all the international layouts.  Thanks for your work.  This will
be fixed in the next build of rhpl.
Comment 3 Stepan Kasal 2007-06-06 10:05:14 EDT
First, thank you for your prompt fix!

Then some chatting:

(In reply to comment #2)
> [...] named after a country that hasn't existed for many years now.

Well, the keyboard has never existed and the adjectivum sounds weird, like, e.g.
a Texasian keyboard.

(And the country stopped its existence almost a year before the legendary
release of Mothers' day's Red Hat 1.0.)

> The problem with these sorts of bugs is that they just don't ever get
> discovered until after a release [...]

Actually, the problem is observed each time a czech-keyboard user installs
Fedora, but at that time, he has no bugzilla nowhere nearby.  Then he forgets. 
After a year or two, when he upgrades; "Oh _they_ still have that nonsense there."

But you see, when you strive to upgrade, you have no capacity to register these
details...

Note You need to log in before you can comment on or make changes to this bug.