Bug 242039 - Network Manager connects to WEP but fails with WPA
Network Manager connects to WEP but fails with WPA
Status: CLOSED DUPLICATE of bug 241507
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 08:51 EDT by Steven Stern
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-10 07:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Stern 2007-06-01 08:51:07 EDT
Description of problem:

Network Manager / wpa_supplicant from F7 initial release

Unable to connect two wpa secured networks using iwl3945 drivers on Sony Vaio. 
Connects appropriately to unsecured and WEP networks.  Logs indicate
wpa_supplicant started, but it fails to login.


How reproducible:
Always

Steps to Reproduce:
1. Select WPA secured network
2. Enter network password

  
Actual results:
No connection

Expected results:
Connection

Additional info:
Comment 1 Steven Stern 2007-06-01 15:35:43 EDT
Jun  1 07:21:54 sds-nb NetworkManager: <info>  SUP: sending command
'INTERFACE_ADD wlan0                wext    /var/run/wpa_supplicant ' 
Jun  1 07:21:56 sds-nb wpa_supplicant[3221]: Trying to associate with
00:15:e9:14:fe:a8 (SSID='Bandit' freq=2422 MHz) 
Jun  1 07:21:56 sds-nb wpa_supplicant[3221]: Associated with 00:15:e9:14:fe:a8 
Jun  1 07:21:56 sds-nb wpa_supplicant[3221]: CTRL-EVENT-CONNECTED - Connection
to 00:15:e9:14:fe:a8 completed (auth) [id=0 id_str=] 
Jun  1 07:36:37 sds-nb wpa_supplicant[3221]: CTRL-EVENT-TERMINATING - signal 15
received 
Jun  1 13:27:31 sds-nb NetworkManager: <info>  SUP: sending command
'INTERFACE_ADD wlan0                wext    /var/run/wpa_supplicant ' 
Jun  1 13:27:33 sds-nb wpa_supplicant[3237]: Trying to associate with
00:14:bf:e9:31:6a (SSID='CCIM' freq=2452 MHz) 
Jun  1 13:27:48 sds-nb wpa_supplicant[3237]: Authentication with
00:00:00:00:00:00 timed out. 
Jun  1 13:27:51 sds-nb wpa_supplicant[3237]: CTRL-EVENT-TERMINATING - signal 15
received 
Comment 2 Steven Stern 2007-06-01 15:37:05 EDT
"Bandit" is a WEP network, "CCIM" is a WPA network.
Comment 3 Steven Stern 2007-06-01 16:39:32 EDT
More info from the audit logs, although I'm running in permissive mode.

SELinux is preventing /usr/sbin/NetworkManager (NetworkManager_t) "unlink" to
wlan0 (var_run_t).

SELinux is preventing /usr/sbin/wpa_supplicant (NetworkManager_t) "rmdir" to
wpa_supplicant (var_run_t).
Comment 4 George N. White III 2007-06-04 09:16:26 EDT
I also get the SELinux messages (permissive mode).

I can't connect using WPA-PSK, using NetworkManager with ndiswrapper and a USB
dongle that worked under FC5.  'deadend' is an Apple Airport Extreme and WEP
is disabled.

Jun  3 05:40:18 cerberus kernel: ndiswrapper version 1.41 loaded (smp=yes)
Jun  3 05:40:18 cerberus kernel: usbcore: registered new interface driver
ndiswrapper
Jun  3 05:40:53 cerberus kernel: usb 4-2.4: new high speed USB device using
ehci_hcd and address 4
Jun  3 05:40:53 cerberus kernel: usb 4-2.4: configuration #1 chosen from 1 choice
Jun  3 05:40:53 cerberus kernel: usb 4-2.4: reset high speed USB device using
ehci_hcd and address 4
Jun  3 05:40:53 cerberus kernel: ndiswrapper: driver sis162u (Silicon Integrated
Systems Corp.(1.05.01),10/26/2004,5.1.1039.1050) loaded
Jun  3 05:40:54 cerberus kernel: wlan0: ethernet device 00:40:f4:c7:81:2d using
NDIS driver: sis162u, version: 0x10500000, NDIS version: 0x501, vendor:
'Wireless Driver', 0457:0162.F.conf
Jun  3 05:40:54 cerberus kernel: wlan0: encryption modes supported: WEP; TKIP
with WPA; AES/CCMP with WPA
Jun  3 05:40:54 cerberus kernel: ndiswrapper: changing interface name from
'wlan0' to 'eth1'
Jun  3 05:40:54 cerberus NetworkManager: <info>  eth1: Device is fully-supported
using driver 'ndiswrapper'. 
Jun  3 05:40:54 cerberus NetworkManager: <info>  nm_device_init(): waiting for
device's worker thread to start 
Jun  3 05:40:55 cerberus NetworkManager: <info>  nm_device_init(): device's
worker thread started, continuing. 
Jun  3 05:40:55 cerberus NetworkManager: <info>  Now managing wireless (802.11)
device 'eth1'. 
Jun  3 05:40:55 cerberus NetworkManager: <info>  Deactivating device eth1. 
Jun  3 05:40:55 cerberus NetworkManager: <WARN> 
nm_device_802_11_wireless_set_essid(): error setting ESSID to '' for device
eth1: Invalid argument 
[...]
Jun  3 05:42:49 cerberus NetworkManager: <info>  User Switch:
/org/freedesktop/NetworkManager/Devices/eth1 / deadend 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Deactivating device eth1. 
Jun  3 05:42:49 cerberus NetworkManager: <WARN> 
nm_device_802_11_wireless_set_essid(): error setting ESSID to '' for device
eth1: Invalid argument 
Jun  3 05:42:49 cerberus dhcdbd: message_handler: message handler not found
under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
Jun  3 05:42:49 cerberus NetworkManager: <info>  Device eth1 activation
scheduled... 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Activation (eth1) started... 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) scheduled... 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) started... 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) scheduled... 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Activation (eth1) Stage 1 of 5
(Device Prepare) complete. 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) starting... 
Jun  3 05:42:49 cerberus NetworkManager: <info>  Activation (eth1/wireless):
access point 'deadend' is encrypted, and a key exists.  No new key needed. 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command
'INTERFACE_ADD eth1               wext    /var/run/wpa_supplicant ' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command 'AP_SCAN 2' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command 'ADD_NETWORK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was '0' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 ssid 64656164656e64' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 scan_ssid 1' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 proto WPA' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 key_mgmt WPA-PSK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command
'SET_NETWORK 0 psk <key>' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: sending command
'ENABLE_NETWORK 0' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  SUP: response was 'OK' 
Jun  3 05:42:50 cerberus NetworkManager: <info>  Activation (eth1) Stage 2 of 5
(Device Configure) complete. 
Jun  3 05:42:50 cerberus wpa_supplicant[3147]: Trying to associate with SSID
'deadend' 
Jun  3 05:43:10 cerberus NetworkManager: <info>  Activation (eth1/wireless):
association took too long (>20s), failing activation. 
Jun  3 05:43:10 cerberus NetworkManager: <info>  Activation (eth1) failure
scheduled... 
Jun  3 05:43:10 cerberus NetworkManager: <info>  Activation (eth1) failed for
access point (deadend) 
Jun  3 05:43:10 cerberus NetworkManager: <info>  Activation (eth1) failed. 
Jun  3 05:43:10 cerberus NetworkManager: <info>  Deactivating device eth1. 
Jun  3 05:43:10 cerberus wpa_supplicant[3147]: CTRL-EVENT-TERMINATING - signal
15 received 
Jun  3 05:43:10 cerberus NetworkManager: <WARN> 
nm_device_802_11_wireless_set_essid(): error setting ESSID to '' for device
eth1: Invalid argument 
Comment 5 Hans de Goede 2007-06-10 07:55:33 EDT
The selinux problems are known and are being worked on, see bug 242015

But since you are running in permissive mode, those aren't the problem. The
iwl3945 in the F-7 kernel has known troubles working with wpa.

There is an F7 kernel-update candidate available here:
http://people.redhat.com/davej/kernels/Fedora/fc7/RPMS.kernel/

Which amongst other things contains various fixes to the iwl3945 driver. Please
try this kernel and report back how it works for you.

Always be carefull when testing new kernels. Use rpm -ivh to install the new
kernel besides your current one so that you can always boot back into the old
kernel.

---

Also this problem has already been reported as bug 241507 , closing as a
duplicate of that bug.


*** This bug has been marked as a duplicate of 241507 ***

Note You need to log in before you can comment on or make changes to this bug.