Bug 242058 - Anaconda ignores changes to package selection after dependencies have been processed
Summary: Anaconda ignores changes to package selection after dependencies have been pr...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-01 14:15 UTC by Lukas Middendorf
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 21:02:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lukas Middendorf 2007-06-01 14:15:36 UTC
Description of problem:
I used the text-mode installer of F7. After choosing the desired groups of
packages to install, the installer began to process package dependencies (Don't
know exactly what it was called, but it should be clear what is meant). While I
had to wait I saw that I can make detailed changes to the package-selection via
F2, and after anaconda finished its calculations, I went back and added some
more packages.
Unfortunately anaconda seems to have totally ignored these changes. Processing
package dependencies for the second time went on in a few seconds (compared to
about two minutes in the first run) and on the installed systems none of the
packages I wanted to add seems to have been installed.

Version-Release number of selected component (if applicable):
Fedora 7 Final

How reproducible:
Did not try to reproduce by now. Perhaps I will do it later.

Steps to Reproduce:
1. Start Installer in Text mode
2. Go through the process until package dependencies have been processed 
3. go back and add some more packages
4. Finish installation
  
Actual results:
Additional package choice is ignored

Expected results:
I wanted to have these packages installed

Additional info:

Comment 1 David Cantrell 2007-08-22 21:02:50 UTC
Not sure what you were doing on tty2 to change the package selection, but this
is not a bug.  tty2 provides a shell for advanced users.  Depsolving takes a
while and you just have to wait for that complete for the installation to proceed.


Note You need to log in before you can comment on or make changes to this bug.