Bug 242067 - squid consumes 90% of cpu
squid consumes 90% of cpu
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
6
i386 Linux
low Severity low
: ---
: ---
Assigned To: Martin Nagy
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 10:51 EDT by Jochen Schlick
Modified: 2016-07-26 19:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 15:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schlick 2007-06-01 10:51:49 EDT
Description of problem:
during the last days I noticed that squid is the main player on my Fedora Core 6
system. It consumes mostly between 80 and 90% of my cpu when I can trust the
output of top.

here one example: 
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
28836 squid     25   0 16456 8420 2328 R 92.1  1.1  19:38.88 squid

It starts on this Tuesday (5/29/2007) and I have absolutely no idea why
this happens. 
When I attach ddd to squid I see always the following backtrace

#4 0x0804e981 in ?? ()
#3 0x4d89df2c in __libc_start_main () from libc.so.6
#2 0x0809ad55 in ipcache_purgelru ()
#1 0x4db3ac93 in __waitpid_nocancel () from libpthread.so.0
#0 0xffffe410 in __kernel_vsyscall ()
 
I've rebuilt it from source rpm - no sucess, same result.


Version-Release number of selected component (if applicable):
squid-2.6.STABLE12-1.fc6
squid-2.6.STABLE13-1.fc6

How reproducible:

Steps to Reproduce:
1. starting squid 
2. surfing

Additional info:
privoxy and squid are running as proxies for internet browsing
Comment 1 Martin Nagy 2008-03-07 11:20:28 EST
We now have:
squid-2.6.STABLE16-2.fc7
squid-2.6.STABLE17-1.fc8
squid-3.0.STABLE1-3.fc9

Is this bug still applicable to any of these releases?
Comment 2 Jochen Schlick 2008-03-10 07:11:37 EDT
I gave up using squid the last half year on this host. Due to your mail I
started squid again this morning and installed the debuginfo. The problem still
exist (version squid-2.6.STABLE17-1.fc8). The only difference to my fedora
systems at home (where squid-privoxy runs fine) is that this squid-privoxy chain
is not connected to the internet directly. It has to use additionally the proxy
of the company.

Using ddd/gdb to attach to the 90%-squid I always see the same backtrace. It
differs from the FC6 version a little bit but it is still in main() at main.c:1027
 
#0  0xffffe410 in __kernel_vsyscall ()
#1  0x4faf8453 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x0809b825 in main (argc=2, argv=0xbfbd1294) at main.c:1027
#3  0x4f974390 in __libc_start_main () from /lib/libc.so.6
#4  0x0804e9b1 in _start ()


Comment 3 Martin Nagy 2008-03-10 08:17:07 EDT
You can try to run squid as 'squid -N', this should workaround the issue. I
haven't tried this, it's just a good guess by looking at the code, so let me
know if it helped. Other workaround would be to try the squid from rawhide which
was largely rewritten, so I think it might work fine. Anyway, if you'd at least
try, let me know (BTW, if you do, watch out for configuration file, there have
been some really major changes there, so squid 3 doesn't work with default 2
configuration).

Also, could you please attach your squid.conf? You also mentioned that you also
use privoxy, can you try to run squid without it, if the behavior is the same?
And if no, please also attach configuration of privoxy. Thanks.
Comment 4 Martin Nagy 2008-03-13 07:58:46 EDT
BTW, what version of fedora are you running on?
Comment 5 Bug Zapper 2008-04-04 03:20:56 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Bug Zapper 2008-05-06 15:39:04 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.